RapidMiner

Bug Report : Generate Concatenation , Select Attributes

Highlighted
Elite III

Bug Report : Generate Concatenation , Select Attributes

Hi guys,

 

I've found that if the pipe | character is used in an attribute name when Select Attributes tries to select it using Subset it will split the attributes into two.  

See below example.  

 

<?xml version="1.0" encoding="UTF-8"?><process version="7.6.000">
  <context>
    <input/>
    <output/>
    <macros/>
  </context>
  <operator activated="true" class="process" compatibility="7.6.000" expanded="true" name="Process">
    <process expanded="true">
      <operator activated="true" class="operator_toolbox:create_exampleset_from_doc" compatibility="0.4.001" expanded="true" height="68" name="Create ExampleSet" width="90" x="179" y="85">
        <parameter key="Input Csv" value="att1,att2&#10;val1,val2"/>
      </operator>
      <operator activated="true" class="generate_concatenation" compatibility="7.6.000" expanded="true" height="82" name="Generate Concatenation" width="90" x="313" y="85">
        <parameter key="first_attribute" value="att1"/>
        <parameter key="second_attribute" value="att2"/>
        <parameter key="separator" value="|"/>
      </operator>
      <operator activated="true" class="select_attributes" compatibility="7.6.000" expanded="true" height="82" name="Select Attributes" width="90" x="447" y="85">
        <parameter key="attribute_filter_type" value="subset"/>
        <parameter key="attribute" value="att1|att2"/>
        <parameter key="attributes" value="att1|att2"/>
        <description align="center" color="transparent" colored="false" width="126">Note in here a subset is chosen to select the attribute att1|att2 However it will change to att1 att2 on execution.</description>
      </operator>
      <connect from_op="Create ExampleSet" from_port="output" to_op="Generate Concatenation" to_port="example set input"/>
      <connect from_op="Generate Concatenation" from_port="example set output" to_op="Select Attributes" to_port="example set input"/>
      <connect from_op="Select Attributes" from_port="example set output" to_port="result 1"/>
      <portSpacing port="source_input 1" spacing="0"/>
      <portSpacing port="sink_result 1" spacing="0"/>
      <portSpacing port="sink_result 2" spacing="0"/>
    </process>
  </operator>
</process>
-- Training, Consulting, Sales in China, Hong Kong & Taiwan --
www.RapidMinerChina.com
1 REPLY
Community Manager

Re: Bug Report : Generate Concatenation , Select Attributes

Hi @JEdward - well that's an interesting one!  Yes that's easily replicated here on my machine.  OK I will pass that along.  Maybe this is a bug that can be a feature?  Smiley Happy

 

Thanks.


Scott

Scott Genzer
Senior Community Manager
RapidMiner, Inc.