RapidMiner

RapidMiner Server fails to store large data in its repository due to a Transaction rollback. What to do

by RMSupport on ‎05-26-2016 06:04 AM

Problem:

When storing data into the server repository, it is stored into the RM Server database. This happens within a transaction (a block operation so to say) which has a default timeout. If that timeout is exceeded because of the size of the data, the transaction fails and is rolled back with an error.

Solution:

It is generally not advisable to store huge data in the server repository. Instead, the data should be stored directly in a database via a database operator in RapidMiner. If that is not an option, the default timeout of 5 minutes can be increased in the server configuration. To do so, follow these steps:

  1. navigate to your RapidMiner Server installation folder, go into the standalone/configuration subfolder and open the standalone.xml file

  2. Find the following element and increase the value (timeout in seconds):

              <coordinator-environment default-timeout="300"/>