RapidMiner

Enabling R Scripting

SOLVED
Regular Contributor

Enabling R Scripting

I'd like to try R scripting for the first time, but I'm struggling to get the R extension properly installed despite having read a number of posts on the topic.   I'm running macOS Sierra 10.12.1, and after completing the steps below, I get the message: path to Rscript front end seems to be incorrect.  But I can't see the problem in the path.  Can anyone please help?

 

 

Steps Completed

Installed R3.3.2

Installed Java Version 8 Update 112

Installed rJava and JavaGD via R

My Bash_Profile includes these lines

  • export R_HOME=/Library/Frameworks/R.framework/Versions/3.3/Resources/Library
  • export JAVA_HOME=/Library/Java/JavaVirtualMachines/jdk1.8.0_112.jdk/Contents/Home

RM preferences path to Rscript:  /Library/Frameworks/R.framework/Versions/3.3/Resources/library/rJava/jri/libjri.jnilib

2 REPLIES
Highlighted
Community Manager

Re: Enabling R Scripting

R Scripting is deprecated and no longer supported. You no longer need to install rJava, see: http://community.rapidminer.com/t5/RapidMiner-Studio/execute-R-vs-execute-script-R/m-p/31956#M22852

 

Use the Execute R extension instead!

Regards,
T-Bone
Twitter: @neuralmarket
Regular Contributor

Re: Enabling R Scripting

Thanks Thomas.  

 

I entered:

/Library/Frameworks/R.framework/Versions/3.3/Resources/Rscript

into Preferences > R scripting, and will use the Execute R operator.