RapidMiner

No Class Def Found Error Hadoop

Highlighted
Contributor II

No Class Def Found Error Hadoop

Hi Sir,

I try run Hadoop with single mode on Rapidminer. Howerver, I got issue . I using Rapidminer Studio 7.5

java.util.concurrent.ExecutionException: java.lang.NoClassDefFoundError: Could not initialize class org.apache.hadoop.yarn.conf.YarnConfiguration
	at java.util.concurrent.FutureTask.report(FutureTask.java:122)
	at java.util.concurrent.FutureTask.get(FutureTask.java:192)
	at com.rapidminer.pagerank.utilities.HadoopUtilities.runHadoopLocal(HadoopUtilities.java:173)
	at com.rapidminer.pagerank.operator.PageRankOperator.doWork(PageRankOperator.java:78)
	at com.rapidminer.operator.Operator.execute(Operator.java:1004)
	at com.rapidminer.operator.execution.SimpleUnitExecutor.execute(SimpleUnitExecutor.java:77)
	at com.rapidminer.operator.ExecutionUnit$3.run(ExecutionUnit.java:812)
	at com.rapidminer.operator.ExecutionUnit$3.run(ExecutionUnit.java:1)
	at java.security.AccessController.doPrivileged(Native Method)
	at com.rapidminer.operator.ExecutionUnit.execute(ExecutionUnit.java:807)
	at com.rapidminer.operator.OperatorChain.doWork(OperatorChain.java:428)
	at com.rapidminer.operator.Operator.execute(Operator.java:1004)
	at com.rapidminer.Process.run(Process.java:1315)
	at com.rapidminer.Process.run(Process.java:1179)
	at com.rapidminer.Process.run(Process.java:1132)
	at com.rapidminer.Process.run(Process.java:1127)
	at com.rapidminer.Process.run(Process.java:1117)
	at com.rapidminer.gui.ProcessThread.run(ProcessThread.java:65)

In build.gradle

dependencies {
	//compile 'com.google.guava:guava:18.0'
	compile "org.apache.hadoop:hadoop-hdfs:2.7.3"
	compile "org.apache.hadoop:hadoop-client:2.7.3"
	compile "org.apache.hadoop:hadoop-mapreduce-client-core:2.7.3"
	compile "org.apache.hadoop:hadoop-yarn-common:2.7.3"
	compile "org.apache.hadoop:hadoop-mapreduce-client-jobclient:2.7.3"
	compile "org.apache.hadoop:hadoop-yarn-client:2.7.3"
	compile "org.apache.hadoop:hadoop-yarn:2.7.3"
	compile "org.apache.hadoop:hadoop-common:2.7.3"
}

Can everyone help me?