[SOLVED] Local Polynomial Regression working only with real labels

Regular Contributor

[SOLVED] Local Polynomial Regression working only with real labels


  I think this (Local Polynomial Regression requiring real labels) is a feature, but I am not not sure why it is not set to the required metadata of the operator input. So I am curious is there a combination of parameters which can handle nominal label in the input?
Here is a process failing only upon executiion (works fine with the [tt]//Samples/data/Polynomial[/tt] location):
<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<process version="5.2.008">
 <operator activated="true" class="process" compatibility="5.2.008" expanded="true" name="Process">
   <process expanded="true" height="427" width="675">
     <operator activated="true" class="local_polynomial_regression" compatibility="5.2.008" expanded="true" height="76" name="Local Polynomial Regression" width="90" x="179" y="30">
       <parameter key="use_weights" value="false"/>
     <connect from_port="input 1" to_op="Local Polynomial Regression" to_port="training set"/>
     <connect from_op="Local Polynomial Regression" from_port="model" to_port="result 1"/>
     <connect from_op="Local Polynomial Regression" from_port="exampleSet" to_port="result 2"/>
     <portSpacing port="source_input 1" spacing="0"/>
     <portSpacing port="source_input 2" spacing="0"/>
     <portSpacing port="sink_result 1" spacing="0"/>
     <portSpacing port="sink_result 2" spacing="0"/>
     <portSpacing port="sink_result 3" spacing="0"/>

Here is the error message:

Thanks, gabor
Super Contributor

Re: Local Polynomial Regression working only with real labels

Hi Gabor,

Local Polynominal Regression is not capable of handling nominal labels. You'll have to use another operator for that.

Concerning the metadata, I just created an internal ticket requesting to add the check to the metadata processing. Thanks for reporting!

Best regards,