RapidMiner

Windows 10 - Scaling Issue

SOLVED
Highlighted
Moderator

Re: Windows 10 - Scaling Issue

Please try the recently released RapidMiner Studio 7.3 and follow this documentation page according to your operating system:

http://docs.rapidminer.com/studio/installation/hidpi.html

Please report if it did or did not resolve your problem with high-resolution displays.

Thanks, Zoltan

______________________
Zoltan Prekopcsak, VP Engineering
Contributor II

Re: Windows 10 - Scaling Issue

it did not work 

 

the final step could not be performed 

  1. Finally you will need to adjust the scaling via your display settings. Go to Control Panel > Appearance and Personalization > Display and run RapidMiner Studio. It should now be displayed with a scaling that fits your high DPI resolution.

the options under control panel were notavailable in win 7 enterprise

Contributor

Re: Windows 10 - Scaling Issue

Recently purchased a new laptop ( ASUS GL552VW running Window 10 home) and after downloading and installing the latest version of RapiMiner Studio I am having the same scaling issue. I have attempted all the suggested fixes with either no or minimal affect. I have come to really appreciate the power of Rapidminer and would very much like to keep it as my primary anylytical tool. However it is presently unusable for me. Please let me know when there is a fix.
Moderator

Re: Windows 10 - Scaling Issue

Hi,

 

can you describe your exact problem? Because all I need to do on my machine is right-click on my Desktop, go to Display Settings, and then move the slider to the right.

 

1.png

 

Regards,

Marco

_________________________________________________________
Team Lead Software Engineering | RapidMiner GmbH
Moderator

Re: Windows 10 - Scaling Issue

@mskinner: Are you sure that the mentioned pre-requisites are satisfied?

 

http://docs.rapidminer.com/studio/installation/hidpi.html

In Windows 7 platforms there are two prerequisites for the scaling adjustment to take effect:

  • You are using an Aero Theme. To check which theme you are currently using, go to Control Panel >Appearance and Personalization > Personalization and make sure to choose a theme under theAero Themes section.
  • You are not using Windows XP DPI scaling. To make sure this is the case, please go to Control Panel> Appearance and Personalization > Display > Set custom text size(DPI) and make sure that Use Windows XP Style DPI scaling is not checked.
______________________
Zoltan Prekopcsak, VP Engineering
Contributor

Re: Windows 10 - Scaling Issue

In reply to Zoltan's post, I just wanted to mention that I followed the steps explained for Windows 7/8.x (involving editing the java.exe and javaw.exe manifests) on my Windows 10 Home edition and it worked just fine. It is actually much better than the Windows 10 solution which involves changing the Display settings, as it requires to be pushed to 300% to have a significant impact, and at this value it messes up a lot of other elements outside RapidMiner.

Contributor

Re: Windows 10 - Scaling Issue

This solution worked perfectly with RapidMiner Studio 7.3 on Microsoft Surface Book.  The Win10 scaling solution provided by RapidMiner is much less desireable.  Thank you alexy.Re:

 

"Windows 10 - Scaling Issue [ New ]

See EDIT2 of this answer, it helped me. I opened this file C:\Program Files\RapidMiner\RapidMiner Studio\jre\bin\javaw.exe in ResTuner and edited Manifest, replacing <dpiAware>true</dpiAware> with <dpiAware>false</dpiAware> "

Contributor

Re: Windows 10 - Scaling Issue

[ Edited ]

I'm incredulous that this can this is an issue for something released over a decade ago.  I'm completely baffled there's not a simple option under 'View' for globally enlarging the font.  Following @mldavis 's solution (editing the manifest with Resource Tuner) worked on Windows 7.  You guys should probably change that line of code in your next release.

Moderator

Re: Windows 10 - Scaling Issue

Hi,

 

unfortunately, the whole scaling business across platforms and different OS versions for those platforms is not as trivial as it may look from the outside. There are lots of problems associated with it, which is why it's the way it is currently.

 

Some technical details for the interested:

- We provide the "-Dsun.java2d.dpiaware=false" switch when launching RapidMiner Studio, but it does not work everywhere.

- Editing the manifest of the javaw.exe is something we are not allowed to by the legal framework of Java. We cannot edit the file and ship a modified JRE or Oracle could come after us. Only endusers may alter the file once they have installed Studio. Which is why this is detailed in our docs: http://docs.rapidminer.com/studio/installation/hidpi.html

 

Regards,

Marco

_________________________________________________________
Team Lead Software Engineering | RapidMiner GmbH
Contributor

Re: Windows 10 - Scaling Issue

So this solution worked for me on my Windows 10 device (Surface Pro 4):

1. Go to Rapidminer Studio.exe properties (right click > Properties)

2. Under the "Compatibility" tab check "Override high DPI scaling behaviour..." and set Scaling perfomed by  to "System"

3. Click "OK"