RapidMiner

RapidMiner

CVS Access from Eclipse 3.3.1

Regular Contributor

CVS Access from Eclipse 3.3.1

Hi Folks!

I've been trying to access CVS using the details documented, but anonymous access without a password is getting refused. What am I missing?
11 REPLIES
Moderator

Re: CVS Access from Eclipse 3.3.1

Hi haddock,

the anonymous access to the RapidMiner repository should be possible using the connection parameters as described here:

http://rapid-i.com/content/view/25/48/.

Another reason for the connection problems may be temporary high traffic on the sourceforge servers. In such cases it can be possible that the occurring delay may exceed a certain limit, making a successful connection impossible. Currently the only solution to this problem is to wait a few hours and to try again. Since this state of affairs is not a very convenient one, we are working on a new repository implementation.

Regards,

Helge
Regular Contributor

Re: CVS Access from Eclipse 3.3.1

Hi,

In my first post on this I said I used the documented settings. I've tried repeatedly today using the same settings. Same results, logging in as "anonymous" with no password always reports an authentication error. All suggestions gratefully received, especially if they work!

Good weekend to all...

Moderator

Re: CVS Access from Eclipse 3.3.1

Hi,

since you used the documented settings, I think this might be a problem of sourceforge. In the last few weeks we often had problems accessing the sourceforge CVS, presumably because of the high traffic as mentioned by Helge. Hence, as Helge already also said, we are planning to implement another repository solution. Because of our high workload at the moment and Ingo being on vacation, this will take some time. Nevertheless at the latest on monday, we will check if there might be some change in the anonymous CVS access settings or another potential reason why you could not access the CVS. Until then, sorry for the inconvenieance ...

Have a nice weekend,
regards,
Tobias
Regular Contributor

Re: CVS Access from Eclipse 3.3.1

Cool, I've just got to get at the metacost operator soon  ;D
Moderator

Re: CVS Access from Eclipse 3.3.1

Hi,

today we checked the anonymous CVS access. The access was relatively slow, but there have been no problems with authentication. Hence, I think Helge is right that the authentication error you experienced is "only" caused by the aforementioned high traffic on the sourceforge servers and the resulting eclipse CVS time-out which then causes to the authentication error. Since, as I said, we will not be able to install a new repository in the short term, the only workaround to gain access to the CVS at the moment is to try again later in the case that high traffic temporarly prevents you from checking out RapidMiner. But I promise, we are definitly working on a new repository, since we appreciate the conveniance of an available and performant repository as much as you do!

Regards,
Tobias
Regular Contributor

Re: CVS Access from Eclipse 3.3.1

Hi,

All most mysterious...I take it that the following is still the correct address

Smiley Tongueserver:anonymous@yale.cvs.sourceforge.net:/cvs/yale

Because I can see it in the CVS repositories pane, and I get a quick connection..... it's authentication that fails - Incorrect user or password

I've extended my timeout, but that doesn't help either.  I have no problem with the Eclipse CVS, so I'm getting very puzzled.

Help!
Moderator

Re: CVS Access from Eclipse 3.3.1

Hi,

haddock wrote:

Smiley Tongueserver:anonymous@yale.cvs.sourceforge.net:/cvs/yale


in my eclipse settings it is

Smiley Tongueserver:anonymous@yale.cvs.sourceforge.net:/cvsroot/yale

Maybe changing the directory to the correct path should work? Otherwise I have definitly no idea why it does not work ...

Regards,
Tobias
Regular Contributor

Re: CVS Access from Eclipse 3.3.1

Indeed, silly me ! I think it got inadvertently changed when I switched the timeout. So Helge was right all along, and now all is fine.

Apologies and thanks  :-\
Moderator

Re: CVS Access from Eclipse 3.3.1

Hi,

no problem. The main thing is that it works now!  So enjoy the bugfixes and extensions of the new developer version ... Smiley Happy

Regards,
Tobias