Problem with IOMultiplier

Contributor II

Problem with IOMultiplier


I am having problem with IOMultiplier and i cannot get it to work. I want to

1) Get the training data
2) Use an GridOptimization to find the best seed number
3)  build a RandomTree with XValidation
4) Use the optimized seed number to build a second Random Tree
5) Print the (optimized) random decision tree

I am using the following setup :

<operator name="Root" class="Process" expanded="yes">
    <operator name="CSVExampleSource" class="CSVExampleSource">
        <parameter key="filename" value="c:\Data\data.csv"/>
        <parameter key="label_name" value="class"/>
    <operator name="IOMultiplier" class="IOMultiplier">
        <parameter key="io_object" value="ExampleSet"/>
        <parameter key="number_of_copies" value="2"/>
    <operator name="GridParameterOptimization" class="GridParameterOptimization" expanded="yes">
        <list key="parameters">
          <parameter key="RandomTree.local_random_seed" value="[1.0;200.0;200;linear]"/>
        <operator name="XValidation" class="XValidation" expanded="yes">
            <parameter key="create_complete_model" value="true"/>
            <parameter key="number_of_validations" value="5"/>
            <operator name="RandomTree" class="RandomTree">
                <parameter key="local_random_seed" value="200"/>
            <operator name="OperatorChain" class="OperatorChain" expanded="yes">
                <operator name="ModelApplier" class="ModelApplier">
                    <list key="application_parameters">
                <operator name="ClassificationPerformance" class="ClassificationPerformance">
                    <parameter key="absolute_error" value="true"/>
                    <parameter key="accuracy" value="true"/>
                    <list key="class_weights">
                    <parameter key="classification_error" value="true"/>
                    <parameter key="normalized_absolute_error" value="true"/>
                    <parameter key="root_mean_squared_error" value="true"/>
                    <parameter key="root_relative_squared_error" value="true"/>
    <operator name="ParameterSetter" class="ParameterSetter">
        <list key="name_map">
          <parameter key="RandomTree" value="NewRandomTree"/>
    <operator name="NewRandomTree" class="RandomTree">
        <parameter key="local_random_seed" value="4"/>

Even though i use an IOMultiplier i get an error message saying that the last RandomTree has missingInput : ExampleSet . I also tried adding an IOSelector...

What am i doing wrong? Please help!!!  ???
Regular Contributor

Re: Problem with IOMultiplier


I tested this setup with the iris-dataset and it worked (completed succesfully).

Did you get the error executing the process or click the "Validate..."-button  ;D ?

The Validate-Button is working, but is not optimal yet. As far as I see there are some problems left regarding multiple occurences of the same type.

Everything ok with your setup from my side  Smiley Wink ... let's roll


Contributor II

Re: Problem with IOMultiplier

Hi Steffen :-)

Thanks for reply...ok it does run well but the following appears on the log :

ct 3, 2008 12:20:21 PM: Initialising process setup
P Oct 3, 2008 12:20:21 PM: [NOTE] No filename given for result file, using stdout for logging results!
P Oct 3, 2008 12:20:21 PM: Checking properties...
P Oct 3, 2008 12:20:21 PM: Properties are ok.
P Oct 3, 2008 12:20:21 PM: Checking process setup...
P Oct 3, 2008 12:20:21 PM: Inner operators are ok.
P Oct 3, 2008 12:20:21 PM: Checking i/o classes...
P Oct 3, 2008 12:20:21 PM: [Error] NewRandomTree: NewRandomTree: NewRandomTree: Missing input: ExampleSet
P Oct 3, 2008 12:20:21 PM: [Error] There was 1 error.
P Oct 3, 2008 12:20:21 PM: Process initialised
P Oct 3, 2008 12:20:21 PM: [NOTE] Process starts

So the RandomTree outputs an error. I tried removing the IOMultiplier and when i did that the process did not complete so you are absolutely right :-)

Thanks for help!