🥳 RAPIDMINER 9.9 IS OUT!!! 🥳

The updates in 9.9 power advanced use cases and offer productivity enhancements for users who prefer to code.

CLICK HERE TO DOWNLOAD

Simple GUI scrolling/resizing question

keithkeith Member Posts: 157  Guru
edited November 2018 in Help
Hi again,

I feel really dumb for having to ask this... how do you scroll down when viewing a NeuralNet graph?

I have created an operator chain that contains a NeuralNet node.  I'm using a simple 1 hidden layer network with 10 nodes in the hidden layer, about 12 inputs, and one output node.  I have successfully processed the chain, and the Neural Net model is one of the outputs.  On the results view, there is a Neural Net tab, which I can select.  When I switch to Graph View, I see a diagram of the network. 

Or in my case, I see a portion of the network, because it doesn't fit in the window.  I am assuming the GUI is supposed to let me view/browse the entire network graph.

However, I can not seem to move, zoom out, scroll down, or otherwise reposition the diagram to fit in the window.  All I can see is the upper portion.  I can drag the bar below the window down to shrink the log window and view somewhat more of the network, but I still can't do anything with the contents of the diagram window itself.  I have tried click-and-drag, right click, simultaneous left-right click, and checked all of the menu options.  It seems like there should be a scroll bar on the right, but there isn't one.

These appears to be limited to Neural Net nodes.  If I replace it with a W-REPTree node, and view the tree it creates, I can drag it around the screen with no problem. 

I tried updating to the latest Java, and uninstalling/reinstalling RapidMiner, with no change in the behavior.  This appears to be strictly a GUI problem -- there doesn't appear to be anything wrong with the actual processing of the model.  I am running RM 4.2 on Windows XP.

I know this is a simple-minded question, but what am I missing? 

Thanks,
Keith

Answers

  • TobiasMalbrechtTobiasMalbrecht Moderator, Employee, Member Posts: 291  RM Product Management
    Hi Keith,
    keith wrote:

    I know this is a simple-minded question, but what am I missing? 
    well, (unfortunately ;)) you do not seem to be missing anything at all. But rather we seem to have missed thinking about the case that such a neural net does not fit on the screen entirely. It might as well be that the developer who was in charge of implementing the [tt]NeuralNet[/tt] presumed that the user would have a screen which is large enough if she saved a lot of money by choosing to use a free, but nonetheless powerful open-source data mining tool ... ;)

    But, joking aside, the true answer is: we presumably simply forgot to make the panel scrollable. We will add this to our todo list and post again when we will have eliminated that problem.

    Regards,
    Tobias
  • keithkeith Member Posts: 157  Guru
    Wow, that was not the answer I was expecting!  :o

    Thanks for the explanation.  FWIW, I am running on a 22-inch display with a resolution of 1680x1050, so I don't think we skimped on the hardware.  ;)

    Keith
  • IngoRMIngoRM Administrator, Moderator, Employee, RapidMiner Certified Analyst, RapidMiner Certified Expert, Community Manager, RMResearcher, Member, University Professor Posts: 1,750  RM Founder
    Hi Keith,

    shame on me: this is really true (and it was actually me who did it). I accidentally removed the scroll pane during a revising process of the result rendering introduced in version 4.2. If you are familiar to using CVS, you could access a fixed version there (here is a description how this can be done: http://rapid-i.com/content/view/25/48/ ). Of course this fix will also be part of the next release and of course also of the next update of the Enterprise Edition.

    Thanks for pointing this out and, hey, nice monitor btw  ;)

    Cheers,
    Ingo
Sign In or Register to comment.