Rapidminer can't show results after executing own operators

Pascal_WelkePascal_Welke Member Posts: 10 Contributor II
edited November 2018 in Help
Hey there,

I'm freaking out. Two weeks ago everything was fine (except for my own bugs) and now this: I've written some scripting operators that allow the use of matlab syntax inside rapidminer.

My process looks like this:
<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<process version="5.0">
  <operator activated="true" class="process" compatibility="5.0.10" expanded="true" name="Process">
    <process expanded="true" height="616" width="768">
      <operator activated="true" class="generate_data" compatibility="5.0.10" expanded="true" height="60" name="Generate Data" width="90" x="54" y="22"/>
      <operator activated="true" class="igg:matlab_environment" compatibility="5.0.1" expanded="true" height="76" name="Matlab Environment" width="90" x="313" y="30">
        <process expanded="true" height="616" width="768">
          <operator activated="true" class="igg:matlab_multi_command_op" compatibility="5.0.1" expanded="true" height="60" name="matcommand" width="90" x="301" y="136">
            <parameter key="command" value="matlabOutput = zeros(10);"/>
          <connect from_port="input 1" to_op="matcommand" to_port="example set"/>
          <connect from_op="matcommand" from_port="example set" to_port="output 1"/>
          <portSpacing port="source_input 1" spacing="0"/>
          <portSpacing port="source_input 2" spacing="0"/>
          <portSpacing port="sink_output 1" spacing="0"/>
          <portSpacing port="sink_output 2" spacing="0"/>
      <operator activated="true" class="write_aml" compatibility="5.0.10" expanded="true" height="60" name="Write AML" width="90" x="542" y="108">
        <parameter key="example_set_file" value="\\tigris\home1$\pwelke\Eigene Dateien\test.dat"/>
        <parameter key="attribute_description_file" value="\\tigris\home1$\pwelke\Eigene Dateien\test.aml"/>
      <connect from_op="Generate Data" from_port="output" to_op="Matlab Environment" to_port="input 1"/>
      <connect from_op="Matlab Environment" from_port="output 1" to_op="Write AML" to_port="input"/>
      <connect from_op="Write AML" from_port="through" to_port="result 1"/>
      <portSpacing port="source_input 1" spacing="0"/>
      <portSpacing port="sink_result 1" spacing="0"/>
      <portSpacing port="sink_result 2" spacing="0"/>
The .aml and .dat files produced by the "Write AML" operator contain the desired data. But at the end of the process when I switch to the result view that view freezes and shows nothing.
What did I do wrong?
My Operator converts the results of matlabs work as a MemoryExampleTable t containing DoubleArrayDataRows and delivers t.createExampleSet()

Best Answer

  • fischerfischer Member Posts: 439 Maven
    Solution Accepted

    maybe the perspective crashed when RM tries to find a dockable that is no longer there.

    Try these:

    - View -> Restore default perspective (Switch to the broken perspective before you do that. Maybe it is not frozen, but doesn't display anything.)
    - In your home folder, delete .RapidMiner5/vlperspective-*.xml



  • fischerfischer Member Posts: 439 Maven

    How do you expect anyone to answer this question without having your operator?
    You probably want to suspend your AWT thread and debug.

  • pablucu5pablucu5 Member Posts: 15 Maven
    I have the same problem. I was creating a plugin that modifies a little bit the GUI. Today I started the RM5 (from Eclipse) and when the program had to show the result perspective it didn't show that perspective. I tried to solve the problem but It didn't worked, I tried to:

    Erase the plugin from the plugin directory.
    Replace the src code of the Eclipse project by a non-modified-src-code, recompiled and ran it again.
    Inizializate the RM5 installed on my pc and the result perspective didn't work neither!
    Unisntalled the RM5, downloaded last version, installed again.

    When I run the program I can move between welcome and design perspective without any problem but it freezes (just that view, not the program) when choosing the result perspective (or when the program is suposed to change to that perspective).

    So, I'm not able to run RM5 even re-installing it. Maybe it has some config file somewhere, I don't know how to solve the problem.
  • pablucu5pablucu5 Member Posts: 15 Maven
    Thank you very much, problem solved! ;D

    This was the key: - In your home folder, delete .RapidMiner5/vlperspective-*.xml
  • Pascal_WelkePascal_Welke Member Posts: 10 Contributor II
    That did the trick with me, too. Thanks.
    Sorry for not providing more information on my operators in the last weeks. I`m only working part time of a part time student job on this particular thing and got lost in other stuff.
    I didn't paste code in the first place because I was pretty shure, the freezing wasn't my fault ;)
  • larriemolarriemo Member Posts: 1 Contributor I

    I delete all files with a recent date of generation and it's works me

Sign In or Register to comment.