"Problem installing rapidminer on mac"

swoosh84swoosh84 Member Posts: 1 Contributor I
edited May 2019 in Help
Hi to all :D

I have tried to download and execute rapidminer but it does't work. :'(

My SO is MAc os x 10.5 so i decide to download the zipfile
before unziping  i tried to lunch (doble clic) on lib/rapidminer.jar.    FAIL
i have grant de execution of script file (rapidminergui and rapidminer). he tel me that output

macbook-di-gaetano-pottino:scripts gaetanopottino$ ./rapidminer
RAPIDMINER_HOME is not set. Trying the directory '.'...
No maximum Java memory defined, using 512 Mb...
Neither ./build nor ./lib/rapidminer.jar was found.
Try 'ant build' or 'ant dist' first or check the value of RAPIDMINER_HOME!

i have tried to set this:
## set the path to your RapidMiner installation here or in an environment variable
RAPIDMINER_HOME=${/Users/gaetanopottino/Downloads/rapidminer}                  FAIL

Some people know how to start it? 

ps: i have already install java 1.6 like you see

macbook-di-gaetano-pottino:scripts gaetanopottino$ java -version
java version "1.6.0_22"
Java(TM) SE Runtime Environment (build 1.6.0_22-b04-307-9M3263)
Java HotSpot(TM) 64-Bit Server VM (build 17.1-b03-307, mixed mode)
macbook-di-gaetano-pottino:scripts gaetanopottino$

Thanks for your time


  • Options
    landland RapidMiner Certified Analyst, RapidMiner Certified Expert, Member Posts: 2,531 Unicorn
    what happens if you start a console, go to the RapidMiner directory and type "java -jar ./lib/rapidminer.jar" ?

  • Options
    AreAre Member Posts: 5 Contributor II

    I also work with Mac but I have got no problems...

    But, like you, I have got similar "error" messages

    G Nov 18, 2010 11:06:02 AM: Property rapidminer.home is not set. Guessing.
    G Nov 18, 2010 11:06:02 AM: Trying parent directory of '/users/Edin/rapidminer/lib/rapidminer.jar'...gotcha!

    Try this:

    1. unzip rapidminer to your user directory
    2. open your terminal and type in following command

    cd rapidminer (or your directory) && cd lib && java -Xmx1600m -jar rapidminer.jar

    The "-Xmx1600m" allows RapidMiner to use the max. RAM of 1,5 GB.

    I use RM 4.6 but I suppose this will also work with 5.0.

    Happy Trying,

  • Options
    pedrourquillapedrourquilla Member Posts: 1 Contributor I
    Hello. I looked at the above possible solutions and still have problems installing rapidminer on my Mac. I have OS X V10.4.11 and when trying to do the above got the following message from the console:

    Exception in thread "main" java.lang.UnsupportedClassVersionError: Bad version number in .class file
            at java.lang.ClassLoader.defineClass1(Native Method)
            at java.lang.ClassLoader.defineClass(ClassLoader.java:620)
            at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:124)
            at java.net.URLClassLoader.defineClass(URLClassLoader.java:260)
            at java.net.URLClassLoader.access$100(URLClassLoader.java:56)
            at java.net.URLClassLoader$1.run(URLClassLoader.java:195)
            at java.security.AccessController.doPrivileged(Native Method)
            at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
            at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
            at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:268)
            at java.lang.ClassLoader.loadClass(ClassLoader.java:251)
            at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:319)

    Any suggestions? I appreciate anyone's help on this. Thank you very much.
  • Options
    landland RapidMiner Certified Analyst, RapidMiner Certified Expert, Member Posts: 2,531 Unicorn
    from your error message I assume that you will need to install Java 1.6. RapidMiner is not Java 1.5 compatible.

    With kind regards,
      Sebastian Land
  • Options
    Iam_molina1Iam_molina1 Member Posts: 1 Newbie
    I have not received the confirmation email and I already tried with two accounts, I cannot start working with the tool since I get a Warning that says that I do not have the account verified
Sign In or Register to comment.