Attribute value type

schillsschills Member Posts: 16 Contributor II
edited November 2018 in Help

How do i change attribute type? When i import data, some of the attributes are automatically changed to integer, when i want them as real numbers.
The wizard i use to import the data does not allow me to select the value of the attribute type.
I have looked at all the operators, and there is nothing there to help me

Please help, i am running rapid miner 5.0



  • Options
    haddockhaddock Member Posts: 849 Maven
    Hi there,

    There  is an operator called "Numerical to Real", which works for me.....

  • Options
    schillsschills Member Posts: 16 Contributor II
    Thankyou Haddock for your speedy reply!

    I have tried using the operator "Numerical to real".
    However the problem is that the data I am using is probabilities in the range 0-1 so any number <0.5 is rounded down to zero when it is recognized as an integer. So essentially rapidminer is changing my data.
    Using the operator to change the attribute type will not help me change my probabilities back to unrounded, non zero values.
    I believe I need to change the attribute value type at the data importing stage, not after using operators when it appears to be too late.
  • Options
    dragoljubdragoljub Member Posts: 241 Contributor II
    What format is your data? What operator is reading it in? Are you running the latest version of RM?

    If you use the import configuration wizard within READ CSV you are able to select the type after the attribute columns are read in. Simply force everything to be a real number.    ;D

Sign In or Register to comment.