Options

"Automatic System Construction XML Error"

mrsmithzmrsmithz Member Posts: 2 Contributor I
edited May 2019 in Help
Hi i just tried to use this plugin but i seem to get an error even using the sample data set "Iris"

Basically i go to tools->Automatic System Construction

select Iris from the sample data set and at step 1, the following error pops up

"Cannot Read from XML Stream, Wrong Format: RegressionModels: RegressionModels"

Under the log entry I get the following:
Jan 4, 2011 7:23:41 PM WARNING: Missing I18N key: gui.dialog.step.regression.title
Jan 4, 2011 7:23:41 PM WARNING: Missing I18N key: gui.dialog.step.evaluate.title
Jan 4, 2011 7:23:41 PM WARNING: Missing I18N key: gui.dialog.classifier_recommender_wizard.icon
Jan 4, 2011 7:23:46 PM WARNING: Missing I18N key: gui.dialog.step.regression.title
Jan 4, 2011 7:23:46 PM WARNING: Using deprecated example set stream version 1

Any help would be appreciated.
Tagged:

Answers

  • Options
    landland RapidMiner Certified Analyst, RapidMiner Certified Expert, Member Posts: 2,531 Unicorn
    Hi,
    you are referring to the Paren extension?

    Greetings,
    Sebastian
  • Options
    mrsmithzmrsmithz Member Posts: 2 Contributor I
    Yes.

    I installed it on my laptop, and it didnt work.  I thought it was my setup or something related to my machine so I installed it in my desktop and I got the same error.  Removal and re-install doesnt seem to help.  Everything else works fine except for this extension.

    Thanks,
  • Options
    PiddiePiddie Member Posts: 6 Contributor II
    I installed Paren extention (and some other updates for Rapidminer) today and get the same error.
    Am I doing the same mistake as mrssmthz or is something wrong with Paren extension?
    Btw, System is Vista 32.
    Have a nice evening

    Peter
  • Options
    landland RapidMiner Certified Analyst, RapidMiner Certified Expert, Member Posts: 2,531 Unicorn
    Hi,
    actually it seems there's an error in the extension.

    This extension is contributed and maintained by the DFKI, so I have to see how we proceed.

    Greetings,
     Sebastian
  • Options
    gvanvuurengvanvuuren Member Posts: 8 Contributor II
    Hi,

    I have the same problem. I've installed RapidMiner with the Paren extension on 3 different computers (Win XP and Win 7), and get the same error message mentioned in the first post.

    Greetings
    Gideon
  • Options
    JEdwardJEdward RapidMiner Certified Analyst, RapidMiner Certified Expert, Member Posts: 578 Unicorn
    Also receiving the same error on install.  Please keep me updated as any updates progress. 
  • Options
    syasya Member Posts: 3 Contributor I
    I got the same error and contacted Dr. Faisal Shafait.

    Solution for now : Use older version of Rapidminer : RapidMiner version (5.0.010) from
    http://sourceforge.net/projects/rapidminer/files/1.%20RapidMiner/5.0/
  • Options
    matthias_reifmatthias_reif Member Posts: 2 Contributor I
    Hi,

    the problem is fixed and the new version of the extension is available via the update server.

    Greetings
    Matthias
  • Options
    johnlennyjohnlenny Member Posts: 2 Contributor I
    Hi,

    I'm still getting "May 11, 2011 11:44:10 PM WARNING: Missing I18N key: gui.dialog.step.evaluate.title" when I try to use Automatic System Construction Tool.

    I have : RapidMiner version 5.1.006 and PaREn Extension version 5.1.000

    When I use the RM updater it indicates that all my extensions are up to date.  Is my paren ext the version which corrected this problem.


    Thanks
    John
  • Options
    tobybtobyb Member Posts: 11 Contributor II
    This same error was reported on March 16, 2011.  I haven't seen the promised update yet.

    http://rapid-i.com/rapidforum/index.php/topic,3437.0.html
  • Options
    JEdwardJEdward RapidMiner Certified Analyst, RapidMiner Certified Expert, Member Posts: 578 Unicorn
    On turning on RapidMiner today I noticed an update to PaRen has just been released (17th of May), give that a try and see if it resolves things. 

    -JEdward
  • Options
    landland RapidMiner Certified Analyst, RapidMiner Certified Expert, Member Posts: 2,531 Unicorn
    Hi,
    yes, we finally released it. Unfortunately there was a very nasty XML encoding problem prevented me from publishing it before my vacation and then it has been forgotten :)

    Greetings,
      Sebastian
  • Options
    botronbotron Member Posts: 1 Contributor I
    Hi All,

    I am a new user (loving the RapidMiner) but having difficulty with the Automatic System Configuration.

    I get the following error:

    Cannot read from XML stream, wrong format: org/xmlpull/v1/XmlPullParserFactory.

    I completely uninstalled and reinstalled the latest versions of RapidMiner (5.2.001) and  PaRen (5.1.1) yesterday.

    Any help greatly appreciated.

    Thanks,

    Bo
  • Options
    cgkolarcgkolar Member Posts: 29 Maven
    I am going to second Bo's error.  It was working fine with 5.2 prior to the update to 5.2.001 that I did yesterday.  Same XML error as noted above.  Let me know if there is anything I can send that would be of help.
  • Options
    cgkolarcgkolar Member Posts: 29 Maven
    On a lark, I manually downloaded the zip file and installed the wizard.jar in the plugins folder.  It will run now without showing the error.

    http://madm.dfki.de/rapidminer/wizard
  • Options
    cgkolarcgkolar Member Posts: 29 Maven
    Premature.  When it tries to load the data it throws an empty error box and then closes.
  • Options
    cgkolarcgkolar Member Posts: 29 Maven
    Confirming that downgrading from 5.2.001 to 5.2.0 restored PAREN operability.
  • Options
    cbwqcbwq Member Posts: 11 Contributor II
    This thread concerns an old error, the current issue should probably be documented elsewhere.
    I've made a new topic here: http://rapid-i.com/rapidforum/index.php/topic,4777.msg17296.html#msg17296

    It is also bug 1048 on the tracker: http://bugs.rapid-i.com/show_bug.cgi?id=1048
  • Options
    cgkolarcgkolar Member Posts: 29 Maven
    Thank you for helping to route this.  CK
  • Options
    rweiss18rweiss18 Member Posts: 1 Contributor I
    I'm also getting the same error.

    Cannot read from XML stream, wrong format: org/xmlpull/v1/XmlPullParserFactory.

    I completely uninstalled and reinstalled the latest versions of RapidMiner (5.2.001) and  PaRen (5.1.1) yesterday.

    Any ideas?
  • Options
    Nils_WoehlerNils_Woehler Member Posts: 463 Maven
    The latest version is 5.2.002 not 5.2.001. The bug you have described is fixed in the latest version.
Sign In or Register to comment.