"Problems with Churn Analysis Wizard: Error message"

User13User13 Member Posts: 155  Guru
edited May 23 in Help
I'm using the wizard. Regardless if I use CSV og XLS, I get the following message:



"The application process cannot be executed on your data. Please make sure the structure of your data matches the one from the demo data. also, make sure to select an appropriate coloumn in step 3."



My data has colums: Churn (with either: yes/no/?), Customer ID, Age, Gender, Login ID, Region Code, County, plus a lot of other data such as sales date, churn date, campaign names, pricing, payment method etc.



In total 40 columns, and a selection/cohort of less than 2000 customers in this initial test of your program.



I tried a lot of different things, including making sure no cell was empty, to no avail. Any ideas what this might be?
Tagged:

Answers

  • User13User13 Member Posts: 155  Guru
    Hi.

    Do you have any rows that have no values for the churn column? The underlying process wants to have a mix of historical churned people (Yes/No) and some missing values for the churn, the ones you want to predict for.

    If this keeps giving you problems, I would suggest to look at the underlying process and see where the hangup is. It could just a be a wrong data type somewhere.

    Cheers,
    Thomas
  • User13User13 Member Posts: 155  Guru
    Thanks, but I'm not quite sure I understand what you mean. They either have churned, or they have not. I don't see how we can have uncertainty wether or not a customer has churned?

    If they have not churned, some are still likely to churn, and I thought that was where the predition was.

    Do you mean using one cohort of historically churned (yes) and not churned (no), then using that as basis for predicting another cohort (the uncertain marked with ?)?

    The only thing I can see right now is encoding, which ought to be UTF-8 (But I can't figure out where to change that in the wizard.) We're based out of Norway, and we use 3 special characters that are being replaced by incorrect characters right now.
  • User13User13 Member Posts: 155  Guru
    Just did another test with Churn marked with either Yes, No or Blank, with same result as last time. Same error message...
  • User13User13 Member Posts: 155  Guru
    "Do you mean using one cohort of historically churned (yes) and not churned (no), then using that as basis for predicting another cohort (the uncertain marked with ?)?"

    The underlying process will split the demo data set into two groups, ones that have a Churn label (yes AND no) and the ones that have it blank (the ones with ?). The group with the churn label is used for training the model (for either yes or no outcomes) and the group with out the churn values is used to score the model. So if your data set only has data for training but not scoring, then you'll get an error msg.

    "The only thing I can see right now is encoding"

    RapidMiner should inherit your System Encoding but its worth to check out. You can set the encoding either in Tools > Preferences > General OR you can set it for the global process, you'd have to open the Accelerator process (lower right of the screen is a link).

    Cheers,
    Thomas
  • User13User13 Member Posts: 155  Guru
    Already tested with encoding, and it did nothing to help. So far, I've:

    - Made sure there's ID, Churn (Yes, No, Blank)
    - Made sure both program and data source is UTF-8
    - Tried TSV, CSV, XLS, XLSX
    - Pasted Excel data into notepad, and saved as various formats to remove possible garbage code from Excel
    - Tested on a different machine
    ...and probably a few other things I can't remember

    Still getting the same error message. Your demo data is the only thing that works...I'm about to give up and try another program...

    Sverre
  • User13User13 Member Posts: 155  Guru
    Hi Sverre,

    Without looking at your data I can't really troubleshoot it. What you can try is opening the process up and attaching a Read Excel operator to the "Filter Label" operator and then go through the Import Wizard Configuration. That will require you to set ID and Label role manually but it should load in all your data.
  • User13User13 Member Posts: 155  Guru
    Hello Sverre,

    You can attach the sample data set to this support case by attaching the file when you reply.

    Thank you,
    Laura
  • User13User13 Member Posts: 155  Guru
    I can send a sample set if you let me know where to send it. I'm a complete noob to RapidMiner, I'm just testing the free trail to see if our company can use this, so any filtering and advanced trouble shooting on my part will probably fail miserably
Sign In or Register to comment.