"SVM Question"

GhostriderGhostrider Member Posts: 60 Contributor II
edited May 2019 in Help
I am trying to use an SVM for the first time.  Here is my setup:

<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<process version="5.1.001">
  <context>
    <input/>
    <output/>
    <macros/>
  </context>
  <operator activated="true" class="process" compatibility="5.1.001" expanded="true" name="Process">
    <process expanded="true" height="615" width="964">
      <operator activated="true" class="retrieve" compatibility="5.1.001" expanded="true" height="60" name="Retrieve" width="90" x="112" y="165">
        <parameter key="repository_entry" value="//MLData/FirstData"/>
      </operator>
      <operator activated="true" class="support_vector_machine_libsvm" compatibility="5.1.001" expanded="true" height="76" name="SVM" width="90" x="246" y="165">
        <list key="class_weights"/>
      </operator>
      <operator activated="true" class="apply_model" compatibility="5.1.001" expanded="true" height="76" name="Apply Model" width="90" x="380" y="165">
        <list key="application_parameters"/>
      </operator>
      <operator activated="true" class="performance" compatibility="5.1.001" expanded="true" height="76" name="Performance" width="90" x="514" y="165"/>
      <connect from_op="Retrieve" from_port="output" to_op="SVM" to_port="training set"/>
      <connect from_op="Apply Model" from_port="labelled data" to_op="Performance" to_port="labelled data"/>
      <connect from_op="Performance" from_port="performance" to_port="result 1"/>
      <portSpacing port="source_input 1" spacing="0"/>
      <portSpacing port="sink_result 1" spacing="0"/>
      <portSpacing port="sink_result 2" spacing="0"/>
    </process>
  </operator>
</process>


I am just trying to apply my model to the training data in hopes of seeing very high prediction...after that I plan to examine more complicated / useful cases.  But my predictions are very poor.  How do I improve the performance of SVM learning?  I have heard / can learn parameter optimization, but isn't there some strictness setting that will at least result in 100% accuracy given though support vectors?
Tagged:

Answers

  • haddockhaddock Member Posts: 849 Maven
    From the link in the SVM Learner help you will see that you need to optimise the parameters ( as in the meta-01 sample ).
Sign In or Register to comment.