🎉 🎉 RAPIDMINER 9.10 IS OUT!!! 🎉🎉

Download the latest version helping analytics teams accelerate time-to-value for streaming and IIOT use cases.

CLICK HERE TO DOWNLOAD

Program closes abruptly

SquirrelXSquirrelX Member Posts: 9 Contributor II
edited November 2018 in Help
I've installed Rapidminer on a Windows 7 64bit machine with the latest Java available, and I get the following: Rapidminer starts up, I can load the latest file I used (or create a new one), but in a couple of seconds, RapidMiner just closes without any warning. I reinstalled Rapidminer and java as well, and I keep getting the same thing: startup, few seconds, close without warning.

Could anyone give me any hints for what might be causing this and how to fix it?

Thanks!

Update: I checked the err files in the folder of Rapidminer, it says I'm out of memory:

# java.lang.OutOfMemoryError: requested 1165616 bytes for Chunk::new. Out of swap space?
#
#  Internal Error (allocation.cpp:272), pid=1748, tid=4576
#  Error: Chunk::new
I did disable swapping so I won't end up with the computer swapping all the time if I run out of physical memory, but why would I need more than 8GB of RAM just to start up RapidMiner and load a project xml file (no running at all)?

Answers

  • landland RapidMiner Certified Analyst, RapidMiner Certified Expert, Member Posts: 2,531   Unicorn
    Hi,
    if you disable Swapping you kill one of the most important functions of the operating system, that is to ensure that all Programs can access their own process private memory independent from other processes.
    If this swapping is disabled, Windows cannot free RAM memory if any process has once used it, even if it will never use it again, because it cannot be written to disk to ensure it will be available again when the program requests access to it.

    Actually Windows 7 now has a Caching process that uses all available memory to cache hard disk accesses. This is a brilliant feature that makes most of you available memory. But if you disable swapping, this cache is never cleared and no process can access the memory again.

    It doesn't make sense to disable swapping at all. You should rather restrict RapidMiner to an amount of memory that is available to avoid swapping.

    Greetings,
      Sebastian
Sign In or Register to comment.