🎉 🎉 RAPIDMINER 9.10 IS OUT!!! 🎉🎉

Download the latest version helping analytics teams accelerate time-to-value for streaming and IIOT use cases.

CLICK HERE TO DOWNLOAD

"Creating new databases"

Legacy UserLegacy User Member Posts: 0 Newbie
edited May 2019 in Help
Hello, i'm new in the rapid miner, and i'm having some trouble with the creation of new databases, take this one for example:

1st part:

<attributeset default_source="clima.dat">

 <attribute
   name         = "Tempo"
   sourcecol    = "1"
   valuetype    = "nominal">
   <value>Ensolarado</value>
   <value>Fechado</value>
   <value>Chuvoso</value>
 </attribute>
 
 <attribute
   name         = "Temperatura"
   sourcecol    = "2"
   valuetype    = "nominal">
   <value>Quente</value>
   <value>Branda</value>
   <value>Fria</value>
 </attribute>
 
 <attribute
   name         = "Umidade"
   sourcecol    = "3"
   valuetype    = "nominal">
   <value>Alta</value>
   <value>Normal</value>
 </attribute>
 
 <attribute
   name         = "Vento"
   sourcecol    = "4"
   valuetype    = "nominal">
   <value>Sim</value>
   <value>Não</value>
 </attribute>
 
 <label
   name         = "Jogar"
   sourcecol    = "5"
   valuetype    = "nominal">
   <value>Sim</value>
   <value>Não</value>
 </label>
 
 
</attributeset>



2nd part:


Ensolarado, Quente, Alta, Não, Não
Ensolarado, Quente, Alta, Sim, Não
Fechado, Quente, Alta, Não, Sim
Chuvoso, Branda, Alta, Não, Sim
Chuvoso, Fria, Normal, Não, Sim
Chuvoso, Fria, Normal, Sim, Não
Fechado, Fria, Normal, Sim, Sim
Ensolarado, Branda, Alta, Não, Não
Ensolarado, Fria, Normal, Não, Sim
Chuvoso, Branda, Normal, Não, Sim
Ensolarado, Branda, Normal, Sim, Sim
Fechado, Branda, Alta, Sim, Sim
Fechado, Quente, Normal, Não, Sim
Chuvoso, Branda, Alta, Sim, Não


I'm saving the first part as clima.aml and the second as clima.dat, but the rapid miner doesn't read them, can anyone help me with this?
Tagged:

Answers

  • IngoRMIngoRM Administrator, Moderator, Employee, RapidMiner Certified Analyst, RapidMiner Certified Expert, Community Manager, RMResearcher, Member, University Professor Posts: 1,751  RM Founder
    Hi,

    could you please provide an error message (if any)? I could imagine that the special character in "Não" could be a problem. In that case, you could change the encoding  in the parameters of the root operator into something appropriate (UTF-8 could help) and should also define the encoding at the beginning of the XML file.

    Cheers,
    Ingo
Sign In or Register to comment.