🎉 🎉   RAPIDMINER 9.5 BETA IS OUT!!!   🎉 🎉

GRAB THE HOTTEST NEW BETA OF RAPIDMINER STUDIO, SERVER, AND RADOOP. LET US KNOW WHAT YOU THINK!

CLICK HERE TO DOWNLOAD

🦉 🎤   RapidMiner Wisdom 2020 - CALL FOR SPEAKERS   🦉 🎤

We are inviting all community members to submit proposals to speak at Wisdom 2020 in Boston.


Whether it's a cool RapidMiner trick or a use case implementation, we want to see what you have.
Form link is below and deadline for submissions is November 15. See you in Boston!

CLICK HERE TO GO TO ENTRY FORM

"Error in Deployment RapidAnalytics on Windows 7"

dranammaridranammari Member Posts: 13 Contributor II
edited May 23 in Help
I am having a problem in deploying RapidAnalytics on my Windows 7 Prof 64-bit laptop. I followed the JBoss bundle installation instructions literally but keep having errors during running. My root directory is C:/rapidanalytics (no blank spaces). My database server is mySQL. I created the user/password/schema rapidanalytics and configured the rapidanalytics-ds.xml file as instructed. The schema tables were created in my database which means that the database connection has no problem. But going to http://localhost:8080 displayes a blank white page (Not the Unable to connect page, which means that JBoss is running but the application deployment failed). I receive the following errors:
17:39:51,292 INFO  [TomcatDeployment] deploy, ctxPath=/RA
17:39:51,432 ERROR [JBossContextConfig] Error calling onStartup for servlet container initializer: com.sun.faces.config.FacesInitializer: java.lang.NoSuchMethodError: javax.servlet.ServletContext.getServletRegistrations()Ljava/util/Map;
at com.sun.faces.config.FacesInitializer.onStartup(FacesInitializer.java:113)
at org.jboss.web.tomcat.service.deployers.JBossContextConfig.lifecycleEvent(JBossContextConfig.java:186)
at org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(LifecycleSupport.java:115)
at org.apache.catalina.core.StandardContext.start(StandardContext.java:4442)
at ...............

17:39:51,451 INFO  [config] Initializing Mojarra 2.0.2 (FCS b10) for context '/RA'
17:39:59,762 SEVERE [config] Unable to instantiate ExpressionFactory 'com.sun.el.ExpressionFactoryImpl'
17:39:59,780 ERROR [[/RA]] Exception sending context initialized event to listener instance of class org.jboss.web.jsf.integration.config.JBossJSFConfigureListener: com.sun.faces.config.ConfigurationException: It appears the JSP version of the container is older than 2.1 and unable to locate the EL RI expression factory, com.sun.el.ExpressionFactoryImpl.  If not using JSP or the EL RI, make sure the context initialization parameter, com.sun.faces.expressionFactory, is properly set.
at com.sun.faces.config.ConfigureListener.registerELResolverAndListenerWithJsp(ConfigureListener.java:638)
at com.sun.faces.config.ConfigureListener.contextInitialized(ConfigureListener.java:241)
at org.jboss.web.jsf.integration.config.JBossJSFConfigureListener.contextInitialized(JBossJSFConfigureListener.java:72)
at org.apache.catalina.core.StandardContext.contextListenerStart(StandardContext.java:3926)
at org.apache.catalina.core.StandardContext.start(StandardContext.java:4447)
at ....................

17:39:59,785 ERROR [StandardContext] Error listenerStart
17:39:59,785 ERROR [StandardContext] Context [/RA] startup failed due to previous errors
17:39:59,821 ERROR [AbstractKernelController] Error installing to Start: name=jboss.web.deployment:war=/RA state=Create mode=Manual requiredState=Installed: org.jboss.deployers.spi.DeploymentException: URL file:/C:/rapidanalytics/server/default/tmp/3lb436b-nfmbxh-gqxyanln-1-gqxybesi-9x/RapidRepositoryWeb.war/ deployment failed
at org.jboss.web.tomcat.service.deployers.TomcatDeployment.performDeployInternal(TomcatDeployment.java:337)
at org.jboss.web.tomcat.service.deployers.TomcatDeployment.performDeploy(TomcatDeployment.java:145)
at org.jboss.web.deployers.AbstractWarDeployment.start(AbstractWarDeployment.java:462)
at org.jboss.web.deployers.WebModule.startModule(WebModule.java:116)
at org.jboss.web.deployers.WebModule.start(WebModule.java:95)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at org.jboss.mx.interceptor.ReflectedDispatcher.invoke(ReflectedDispatcher.java:157)
at org.jboss.mx.server.Invocation.dispatch(Invocation.java:96)
at org.jboss.mx.server.Invocation.invoke(Invocation.java:88)
at org.jboss.mx.server.AbstractMBeanInvoker.invoke(AbstractMBeanInvoker.java:271)
at org.jboss.mx.server.MBeanServerImpl.invoke(MBeanServerImpl.java:670)
at org.jboss.system.microcontainer.ServiceProxy.invoke(ServiceProxy.java:206)
at $Proxy41.start(Unknown Source)
at org.jboss.system.microcontainer.StartStopLifecycleAction.installAction(StartStopLifecycleAction.java:53)
at ..............................

17:40:00,039 INFO  [service] Removing bootstrap log handlers
17:40:00,195 INFO  [org.jboss.system.server.profileservice.ProfileServiceBootstrap] Loading profile: [email protected][domain=default, server=default, name=default]
17:40:00,198 ERROR [org.jboss.system.server.profileservice.ProfileServiceBootstrap] Failed to load profile: Summary of incomplete deployments (SEE PREVIOUS ERRORS FOR DETAILS):

DEPLOYMENTS IN ERROR:
 Deployment "vfszip:/C:/rapidanalytics/server/default/deploy/RapidAnalytics.ear/" is in error due to the following reason(s): org.jboss.deployers.spi.DeploymentException: URL file:/C:/rapidanalytics/server/default/tmp/3lb436b-nfmbxh-gqxyanln-1-gqxybesi-9x/RapidRepositoryWeb.war/ deployment failed
What am I missing here??

Please help! I need to run RapidAnalytics on my machine ASAP.
Many thanks in advance,
Ahmad
Tagged:

Answers

  • fischerfischer Member Posts: 439  Guru
    Hi,

    this is difficult to track from here. Something seems to be severely wrong in your installation, either of Java or JBoss. Seems like you are using a wrong library version somewhere. If you need help ASAP, I strongly recommend purchasing professional support.

    Best,
    Simon
  • zarelaArroyozarelaArroyo Member Posts: 3 Contributor I

    I have the same problem ... please can you tell me if you resolved the problem or how can I resolved it??
  • dranammaridranammari Member Posts: 13 Contributor II
    No success yet, zarelaArroyo.

    Thank you Simon. Can you please elaborate more on what you mean by "wrong library version". I am using the JBoss bundle edition of Rapid Analytics which mean any JBoss libraries must be correct. My java is the sun 1.6.0_24.

    Many thanks,
    Ahmad
Sign In or Register to comment.