"[SOLVED] Nested Operators in Weka don't have ports to connect?"

earmijoearmijo Member Posts: 270 Unicorn
edited June 2019 in Help
I've been playing with Ensemble Models lately. When I try to use the "Meta" operators from Weka (say for instance W-Vote) I don't see inside the operators the input or output ports/connectors. Am I missing something basic?

Thanks in advance for any help



  • Options
    Nils_WoehlerNils_Woehler Member Posts: 463 Maven
    Hi Ernesto,

    Weka Ensemble Models work with Weka classifiers only. You dont have to connect the classifiers, they will get the input automaticly. Here is an example:

    <?xml version="1.0" encoding="UTF-8" standalone="no"?>
    <process version="5.1.014">
     <operator activated="true" class="process" compatibility="5.1.014" expanded="true" name="Process">
       <process expanded="true" height="579" width="708">
         <operator activated="true" class="retrieve" compatibility="5.1.014" expanded="true" height="60" name="Retrieve" width="90" x="150" y="176">
           <parameter key="repository_entry" value="//Samples/data/Sonar"/>
         <operator activated="true" class="weka:W-Vote" compatibility="5.1.001" expanded="true" height="76" name="W-Vote" width="90" x="313" y="165">
           <process expanded="true" height="639" width="950">
             <operator activated="true" class="weka:W-KStar" compatibility="5.1.001" expanded="true" height="76" name="W-KStar" width="90" x="363" y="216"/>
         <connect from_op="Retrieve" from_port="output" to_op="W-Vote" to_port="training set"/>
         <connect from_op="W-Vote" from_port="model" to_port="result 1"/>
         <portSpacing port="source_input 1" spacing="0"/>
         <portSpacing port="sink_result 1" spacing="0"/>
         <portSpacing port="sink_result 2" spacing="0"/>

  • Options
    earmijoearmijo Member Posts: 270 Unicorn
    That was embarrasingly (for me :-)) simple. Thank you very much Nils.
Sign In or Register to comment.