🎉 🎉 RAPIDMINER 9.10 IS OUT!!! 🎉🎉

Download the latest version helping analytics teams accelerate time-to-value for streaming and IIOT use cases.

CLICK HERE TO DOWNLOAD

[SOLVED] Problem with number of numircal digits

eng_bashareng_bashar Member Posts: 2 Contributor I
edited November 2018 in Help
Hello every body

I want to import an excel sheet which have data like this 1.3496 but when I import it to raid miner it become 1.349 , Please help with that

thanx  

Answers

  • IngoRMIngoRM Administrator, Moderator, Employee, RapidMiner Certified Analyst, RapidMiner Certified Expert, Community Manager, RMResearcher, Member, University Professor Posts: 1,751  RM Founder
    Hi,

    I import it to raid miner it become 1.349
    no, that's not true. RapidMiner actually stores the data internally with the full precision but with the default settings, only three digits are displayed in the data view. So this is only a matter of visualization and you can simply work with the data within your process and can be assured that the full precision will be used.

    However, if you want to see the full precision of your data (although data tables quickly get really full then...), you can change the corresponding setting in the preferences. Go to

    Tools -> Preferences -> General -> rapidminer.general.fractiondigits.numbers

    and change to value from "3" to something higher. Don't forget to click "Apply" to save the change for this working session only or "Save" to change it also for the next sessions. The next time you will visualize data, the full precision will be shown.

    Cheers,
    Ingo
  • eng_bashareng_bashar Member Posts: 2 Contributor I

    It works Ok ..... Thank you very much for your help


    Regards
  • BartNBartN Member Posts: 18  Maven
    Just for information: the rapidminer.general.fractiondigits.numbers is also used to truncate the data written to csv files.
Sign In or Register to comment.