RapidMiner 9.7 is Now Available

Lots of amazing new improvements including true version control! Learn more about what's new here.

CLICK HERE TO DOWNLOAD

"Support Vector Machine - Plot View Missing"

Q-DogQ-Dog Member Posts: 32 Contributor II
edited June 2019 in Help
Hello everybody,

I just wanted to implement a simple Support Vector Machine in RapidMiner and noticed that many of the options in the results view were missing.

I only have:
- Text view
- Annotations

According to the online tutorial (and some videos) there should be:
- Text view
- Weight Table
- Support Vector Table
- Plot View
- Annotations

what am I doing wrong? And can you reproduce this behaviour?

Cheers Q-Dog
Tagged:

Answers

  • dromiceiomimusdromiceiomimus Member Posts: 4 Contributor I
    It sounds like you're only outputting the model itself, not an application of the model to your data nor performance measures thereof.

    If you output the "mod" that comes from your SVM block you will see the SVM model.  This is what it sounds like you're doing.

    If you attach your SVM block to an Apply Model block (mod to mod, exa to unl) the apply model will output the same model (mod) and the results of the model applied to the data (exa).  This data might be the plot view your wanting.

    The "wei" node of the SVM block outputs weights, presumably the ones you're looking for.


    Does that help at all?  If you have a link to the tutorial or video I might be able to give better suggestions.  There're so many operators that generate the various outputs you're looking for it's difficult to say what's missing.
  • Q-DogQ-Dog Member Posts: 32 Contributor II
    Hi dromiceiomimus,

    thanks a lot for your answer.

    I meant the following video (at 1:30):
    http://rapidminerresources.com/index.php?page=svm-intro

    In this video even though only the model is connected with the output, you can see all of the views (especially the plot view) I mentioned in my first post.


    Cheers Q-Dog

    // Edit
    Furthermore, it is described in the RapidMiner Tutorial (open Rapidminer: Help -> RapidMiner Tutorial) step 5 of 26
  • dromiceiomimusdromiceiomimus Member Posts: 4 Contributor I
    Oh, I see!  Well, that's quite beyond my ken, I'm afraid.  Hopefully someone with some more experience will chime in.
  • Q-DogQ-Dog Member Posts: 32 Contributor II
    That's a pity.

    Thanks a lot anyway :)
  • pengiepengie Member Posts: 21  Maven
    Apparently Weight Table, Support Vector Table and Plot View were removed from version 5.1.14 onwards. Not sure why they remove them. It is a shame as the information in Support Vector Table is quite useful.
  • Nils_WoehlerNils_Woehler Member Posts: 463  Guru
    Hi,

    I just check with my up-to-date version of RapidMiner and for me everything seems to be fine!
    Are Weight Table, Support Vector Table and Plot View never shown or does this happen just from time to time?

    Greetings
    Nils
  • IngoRMIngoRM Administrator, Moderator, Employee, RapidMiner Certified Analyst, RapidMiner Certified Expert, Community Manager, RMResearcher, Member, University Professor Posts: 1,745  RM Founder
    Hi,

    I also tried this with a fresh SVN version and the views have been missing on my laptop. I tried again in debug mode and, tada, they are back. Could this be a thread problem? This would explain why some people experience this and others do not and maybe even why I got the views in debug mode without changing a line of code. By the way, I already have sent Simon a mail about this containing more details.

    Cheers,
    Ingo
  • pengiepengie Member Posts: 21  Maven
    I have just tried using my RM v5.1.14. The views are back again, without the need to go into debug mode. Very strange indeed. Anyway, glad to hear that they are not removed by design.  :D
  • Q-DogQ-Dog Member Posts: 32 Contributor II
    pengie wrote:

    I have just tried using my RM v5.1.14. The views are back again, without the need to go into debug mode. Very strange indeed. Anyway, glad to hear that they are not removed by design.  :D
    You're right, they are back :)
  • MariusHelfMariusHelf RapidMiner Certified Expert, Member Posts: 1,869   Unicorn
    Don't panic, we are working on it in this very moment :)
  • Nils_WoehlerNils_Woehler Member Posts: 463  Guru
    And now it is fixed. At least in the current SVN version. The next update should fix it for you too.

    Best,
    Nils
Sign In or Register to comment.