[SOLVED] - Generate Report - Report ... Bug

gencis2gencis2 Member Posts: 2 Contributor I
edited April 2019 in Help
Hello,
I am trying to create a report by using "Generate Report" and then "Report".  The format of the report is excel.  I have tried to solve this problem on my own but to no avail.  
I have replicated the identical process as shown on this link: http://www.myexperiment.org/workflows/1279.html.  Every time I run the process, in the log i get the following message:

             "SEVERE: Report: No report specified: skipping reporting operator. Please make all necessary settings in the option dialog."

In the "Generate Report" operator the parameters are:
 - report name: Excel
 - excel output file:  C:\ExcelReport.xls

In the "Report" operator the parameters are:
 - report name: Excel

My Sys Specs. are:
- Win 7 32 bit
- UAC level 0
- Office 2010 (only 2003 format is being used for all excel files -.xls)
- RapidMiner v. 5.1.017
- RapidMiner run mode (always as Admin - just in case because UAC level 0 should take care of this)

Also the output file has a worksheet created with the desired name (Excel in this case).  So it is obvious to me that the issue lies with the "Report" operator (also as suggested by the log).

In simple words, I am just trying to get the results of the process into an excel file.  Is this a known issue?  Is there a workaround? Or am I just not able to see a superbly simple solution?

Thanks in advance for your help.

please find below the xml file....

<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<process version="5.1.017">
 <context>
   <input/>
   <output/>
   <macros/>
 </context>
 <operator activated="true" class="process" compatibility="5.1.017" expanded="true" name="Process">
   <parameter key="resultfile" value="C:\ExcelReport.xls"/>
   <process expanded="true" height="-20" width="-50">
     <operator activated="true" class="generate_data" compatibility="5.1.017" expanded="true" height="60" name="Generate Data" width="90" x="78" y="84"/>
     <operator activated="true" class="correlation_matrix" compatibility="5.1.017" expanded="true" height="94" name="Correlation Matrix" width="90" x="276" y="82"/>
     <operator activated="true" class="reporting:generate_report" compatibility="5.1.000" expanded="true" height="76" name="Generate Report" width="90" x="443" y="83">
       <parameter key="report_name" value="Excel"/>
       <parameter key="format" value="Excel"/>
       <parameter key="excel_output_file" value="C:\ExcelReport.xls"/>
     </operator>
     <operator activated="true" class="reporting:report" compatibility="5.1.000" expanded="true" height="60" name="Report" width="90" x="648" y="51">
       <parameter key="report_name" value="Excel"/>
       <list key="parameters"/>
     </operator>
     <connect from_op="Generate Data" from_port="output" to_op="Correlation Matrix" to_port="example set"/>
     <connect from_op="Correlation Matrix" from_port="example set" to_op="Generate Report" to_port="through 1"/>
     <connect from_op="Generate Report" from_port="through 1" to_op="Report" to_port="reportable in"/>
     <connect from_op="Report" from_port="reportable out" to_port="result 1"/>
     <portSpacing port="source_input 1" spacing="0"/>
     <portSpacing port="sink_result 1" spacing="0"/>
     <portSpacing port="sink_result 2" spacing="0"/>
   </process>
 </operator>
</process>
Tagged:

Answers

  • Nils_WoehlerNils_Woehler Member Posts: 463  Guru
    Hi,

    did you configured the report as stated in the error message? This can be done by selecting the Report operator and then pressing the "Configure Report" button.
    For me everything works fine afterwards.

    Best
    Nils
  • gencis2gencis2 Member Posts: 2 Contributor I
    Hi Nils,

    Thanks for the quick reply.  Yes, I managed to figure that out last night.  I was not aware that the config button had to be pressed... i thought that there would be a default report.  Anyhow, issue solved.

    Thanks a lot.
    ralph
Sign In or Register to comment.