Problem with port 8083

juancarcvijuancarcvi Member Posts: 1 Contributor I
edited November 2018 in Help
Hi

I'm installing RapidAnalytics 1.1.014 Community Edition  (Windows 2008 Server)

I ran  the  installer as Administrator, but at  the end, I’ve  got the message: Service.bat terminated abnormally! Error code: 9.009 service registration may have failed.

If I execute run.bat i get the error:

12:11:04,178 INFO WebService Using RMI server codebase: http:127.0.0.1:8083

12:11:04,181 ERROR AbstractKernelController Error installing to Start: namejboss:serviceWebService stateCreate modeManual requiredStateInstalled: java.lang.Exception: Port 8083 already in use.
at org.jboss.web.WebServer.start(WebServer.java:243) :6.0.0.Final
at org.jboss.web.WebService.startService(WebService.java:323) :6.0.0.Final
.....

The port 8083 is used by other software in my Company and it can’t be changed. Can I change this port for RA? Is  this the origin of the problem  when installing  or is it due to another thing ?

Thanks

JuanCar
Tagged:

Answers

  • AlexeiwAlexeiw Member Posts: 3 Contributor I
    Hi JuanCar, i`ve the same problem, ¿can somebody help us?
  • fischerfischer Member Posts: 439  Guru
    Hi,

    you can change all the ports separately, but the easiest way is to use JBoss port binding sets. E.g., you can start JBoss with

    run -Djboss.service.binding.set=ports-01

    which will offset ports by 100.

    Best,
    Simon
  • AlexeiwAlexeiw Member Posts: 3 Contributor I
    Thanks for your help, it works now!
Sign In or Register to comment.