🎉 🎉 RAPIDMINER 9.10 IS OUT!!! 🎉🎉

Download the latest version helping analytics teams accelerate time-to-value for streaming and IIOT use cases.

CLICK HERE TO DOWNLOAD

problems with 'select by random' operator [SOLVED]

sfmoraissfmorais Member Posts: 13 Contributor II
edited November 2018 in Help
Hi!

I have the same problem than
http://rapid-i.com/rapidforum/index.php/topic,3708.msg13825.html#msg13825
but I didn´t understand the solution.

I have a example set with some atributes. I want select one randomly atribute (for example with 'select by random' operator), but each time that I run the process the selected attribute is always the same.

How can I workaround it ?  (if possible with a example)

Many thanks for the help

Best Regards,
Sérgio Morais

Answers

  • Marco_BoeckMarco_Boeck Team Lead Software Engineering Administrator, Moderator, Employee, Member, University Professor Posts: 1,963   RM Engineering
    Hi,

    that is because the local random seed is fixed by default to allow reproduction of results. You can change that by selecting the process, and change the "random seed" parameter to -1.
    That way, the random function will use the current system time, and you will get a more random selection of attributes.

    Regards,
    Marco
  • sfmoraissfmorais Member Posts: 13 Contributor II
    Hi,

    I tried solve the problem in two different ways:

    1) In my process, in 'select by random' operator I tried changed 'local random seed' to -1 but the value is converted to 1 automatically

    2) In Rapid Miner 'Tools -> Preferences' I changed 'rapidminer.general.randomseed' option to '-1' and apply, and the problem is the same.


    I still with same problem (the selected attribute is always the same)
    (if necessary I send the xml of my problem)

    Many Thanks in advance

    Regards
  • MariusHelfMariusHelf RapidMiner Certified Expert, Member Posts: 1,869   Unicorn
    Hi,

    Marco was referring to the random seed of the Process, not of the operator. Just click an empty space in the process pane to see the properties of the process itself. Set the random seed to -1. Additionally, disable "use local random seed" for the Select by Random operator.

    Best,
    Marius
  • sfmoraissfmorais Member Posts: 13 Contributor II

    Ok! now I understood. It works! 

    Thanks
Sign In or Register to comment.