Error Saving File

devonkyledevonkyle Member Posts: 4 Contributor I
edited November 2018 in Help
I have an Excel file of financial time series data  that  I'm importing . I get an error every time I try to save the file with an attribute of ID. As long as I don't specify an ID, the file will save properly in my repository. If I try specifying my date column as an ID, RM refuses to save my file and I get the following message below. ALl the date values of unique values - no dups. I've even tried replacing the column of dates with a unique integer (1,2,3,4 etc) and I have the same issue. There are NO NULL values in this column. ANy idea what I'm doing wrong.??  I've tried this with multiple files with different attributes - same result. Thanks Devon

Exception: java.util.ConcurrentModificationException
Message: null
Stack trace:

  java.util.LinkedList$ListItr.checkForComodification(Unknown Source)
  java.util.LinkedList$ListItr.next(Unknown Source)
  com.rapidminer.example.SimpleAttributes$1.next(SimpleAttributes.java:99)
  com.rapidminer.example.SimpleAttributes$1.next(SimpleAttributes.java:93)
  com.rapidminer.example.AttributeIterator.hasNext(AttributeIterator.java:59)
  com.rapidminer.operator.nio.model.DataResultSetTranslator.read(DataResultSetTranslator.java:220)
  com.rapidminer.operator.nio.model.WizardState.readNow(WizardState.java:71)
  com.rapidminer.operator.nio.StoreDataWizardStep$1.run(StoreDataWizardStep.java:80)
  com.rapidminer.gui.tools.ProgressThread$2.run(ProgressThread.java:177)
  java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)
  java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
  java.lang.Thread.run(Unknown Source)

Answers

  • Nils_WoehlerNils_Woehler Employee, Member Posts: 463  Guru
    Hi,

    this is an error we know and we already have fixed it. But we haven't made a release yet. Maybe there will be an update today that will fix it.

    Best,
    Nils
  • devonkyledevonkyle Member Posts: 4 Contributor I
    Just ran an update and it looks like it's been fixed! thanks for that... As a new user who is just learning the basics , I assumed I was doing something wrong - I literally spent hours trying to figure out what I was doing wrong before I posted in the forum.
    D
Sign In or Register to comment.