Problem Accessing Remote Repositories-HTTP status code 503: Service Unavailable

mazdamazda Member Posts: 11 Contributor II
edited November 2018 in Help

I am having problem accessing the remote repositories I created few days ago in RapidMiner.  Even when I create a new one I can’t access it and I don’t see the default folders.

When I click on a repository instead of seeing my folders, It shows “Pending…. “  status.

This is the error message It returns: 

" Error fetching folder contents from server. If the error message indicates that the server redirected the request too many times, this is probably due to an incorrect username/password and a BASIC authentication mechanism.
The server sent HTTP status code 503: Service Unavailable "

Here is what I did so far and places I checked:

1-I can see my RepositoryService location in  http://localhost:8080/RAWS/RepositoryService?wsdl
2-Checking the admin-consol at http://localhost:8080/admin-console/ ; I see that my jdbc/RapidAnalyticsDS is up and running
3-I’m accessing the Repository using the admin username and password.  I have also tried other username and passwords.

Any ideas what would be wrong?  What should I check next? 

Thanks,
Mazda
Tagged:

Answers

  • mazdamazda Member Posts: 11 Contributor II
    I have decided to upgrade my RapidAnalytics from version 1.1.014 to version 1.2.002 and hope that this resolves my issue of remote repository. 
    I ran the installation as administrator on windows 7.  However, the installation failed to register the Rapidanalytics as a window service, and complained that I have to run the installation as an administrator which I did.

    Here  is the error message I get:
    “Service creation not successful.  Services can be installed only when running as administrator.  Rapidanalytics service registration may have failed!”

    I still have the old RapidAnalytics service “RA11SVC” on my machine? 
    Any idea how should I resolve this problem  or what I’m doing wrong?

    Thanks,
    Mazda
  • Nils_WoehlerNils_Woehler Member Posts: 463  Guru
    Hi Mazda,

    if you want to install RapidAnalytics as a Windows Service you have to remove the old service first. (http://www.howtogeek.com/howto/windows-vista/how-to-delete-a-windows-service-in-vista-or-xp/)

    Best,
    Nils
  • mazdamazda Member Posts: 11 Contributor II
    Nils, I finally deleted the old RA service and my installation worked.  Thank you so much for your help.

    I still have the same problem creating and accessing remote Repositories from RapidMiner . I have RapidMiner 5.2.3.

    I get the same error I was getting before the installation of RapidAnalytics 1.2.002, which is:
    " Error fetching folder contents from server. If the error message indicates that the server redirected the request too many times, this is probably due to an incorrect username/password and a BASIC authentication mechanism.
    The server sent HTTP status code 503: Service Unavailable "

    The problem is, I can’t access or create remote repositories from RapidMiner 5.2.3.

    Now, if I launch RapidMiner from within RapidAnalytics (version 1.2.002), then RapiAnalytics launches the older version of RapidMiner 5.1.013, then I can access my remote repositories.

    So
    - I’m not sure why RapidAnalytics 1.2.002 runs the older version of the RapidMiner which is RapidMiner 5.1.013,
    And
    - Not sure why I can’t access my remote repositories from  RapidMiner 5.2.3.


    Any idea how to make this work from RapidMiner 5.2.3 and make RapidAnalytics1.2.002 call RapidMiner5.2.3?

    Also, I can't access admin-console anymore. http://localhost:8080/admin-console/
    I get this error:  HTTP Status 404 - /admin-console
    The requested resource (/admin-console) is not available.

    I could connect to it earlier today before reinstalling the new RapidAnalytics.

    Thanks,
    Mazda
  • fischerfischer Member Posts: 439  Guru
    Hi,

    first of all: We removed the admin-console in this release because people started installing RA carelessly on the internet without changing the passord. You can enable them again by renaming the files from "common/deploy.disabled" and "server/default/deploy/*.disabled". Just remove the ".disabled" suffix again.

    The 503 is weird. Can you access http://yourhost:8080/RAWS/RepositoryService?wsdl

    Best,
    Simon
  • mazdamazda Member Posts: 11 Contributor II
    Thank you, I activated the admin-console the way you suggested and it works now.
    But, I'm still getting the same error  trying to access the remote repository from RapidMiner 5.2.

    Any suggestion?

    Thanks,
    Mazda
  • haddockhaddock Member Posts: 849  Guru
    Hi Mazda, Simon, and Nils,

    I have a plugin which passes an example set to CUDA for Association Rules generation, it works fine with RapidMiner but I need to change its build if I want to run it on RapidAnalytics. I need to explicitly state that it requires 5.1, like this..
    <property name="extension.needsVersion" value="5.1" />
    Otherwise I'll get this from RapidAnalytics.
    Cannot register operators from 'Haddock': Dependencies not fulfilled! This plugin needs a RapidMiner version 5.2 and the following plugins:
    []
    Here's the top of the changes.txt for RapidMiner
    History of changes of the RapidMiner versions
    ====================================================

    Changes from RapidMiner 5.2.3 to 5.2.4
    --------------------------------------
    * Excel 2007 support

    Changes from RapidMiner 5.2.1 to 5.2.2
    --------------------------------------
    * Remove Correlated Attributes uses deterministic random numbers
    * Improved Repository Tree handling (save expansion state on refresh and improved tree selection on entry removal)
    * Improved exporting of Advanced Charts View

    Changes from RapidMiner 5.2.0 to 5.2.1
    --------------------------------------
    * Added operators to manage repository entries: Copy, Move, Delete, Rename
    I've also had problems with process deletion and renaming, particularly when executed from within RapidMiner, rather than through the web interface, and therefore ponder whether the mismatch between versions lies behind your problems as well.

    Just my...

  • julianojajulianoja Member Posts: 4 Contributor I
    I have the same problem and a found a "litle solution" to this!

    Sorry about my english! I´m from brazil and don´t write english well!

    So, if you try access RA in older version, you can access the repository if you have two versions of RA installed in your server, and you can save process there, after you can run RA in newst version, because have many operators that don´to work properly in older version, in my case.

    It works for me, i hope that it works for you!

Sign In or Register to comment.