🎉 🎉 RAPIDMINER 9.10 IS OUT!!! 🎉🎉

Download the latest version helping analytics teams accelerate time-to-value for streaming and IIOT use cases.

CLICK HERE TO DOWNLOAD

no idea how to proceed

momnotmommomnotmom Member Posts: 2 Contributor I
edited November 2018 in Help
I am running Linux RedHat and Java 1.7. I connect via ssh. I unzipped RapidMiner in /opt/rapidminer,
went to the folder /opt/rapidminer
and then excuted:

./scripts/RapidMiner

and received:

[[email protected] rapidminer]# ./scripts/rapidminer
RAPIDMINER_HOME is not set. Trying the directory '.'...
No maximum Java memory defined, using 512 Mb...
Starting RapidMiner from '.', using classes from './lib/rapidminer.jar'...
RapidMiner version 5.2.003, Copyright (C) 2001-2012
RapidMiner comes with ABSOLUTELY NO WARRANTY; This is free software,
and you are welcome to redistribute it under certain conditions;
see license information in the file named LICENSE.
Usage: com.rapidminer.RapidMinerCommandLine [-f] PROCESS
  PROCESS  a repository location containing a process
  -f        interpret PROCESS as a file rather than a repository location (deprecated)


This seems to want some sort of repository, which I don't think I have. Is there one provided? OR how do I create one and then name it for RapidMiner to use?

I also tried
./scrpts/RapidMinerGUI
and got:
RAPIDMINER_HOME is not set. Trying the directory '.'...
No maximum Java memory defined, using 512 Mb...
Starting RapidMiner from '.', using classes from './lib/rapidminer.jar'...
Apr 16, 2012 12:03:30 AM com.rapid_i.Launcher ensureRapidMinerHomeSet
INFO: rapidminer.home is '.'.
Apr 16, 2012 12:03:30 AM com.rapid_i.Launcher main
INFO: Launching RapidMiner, platform ANY
Exception in thread "main" java.lang.reflect.InvocationTargetException
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
        at java.lang.reflect.Method.invoke(Method.java:601)
        at com.rapid_i.Launcher.main(Launcher.java:334)
Caused by: java.awt.HeadlessException:
No X11 DISPLAY variable was set, but this program performed an operation which requires it.
        at java.awt.GraphicsEnvironment.checkHeadless(GraphicsEnvironment.java:197)
        at java.awt.Window.<init>(Window.java:534)
        at java.awt.Frame.<init>(Frame.java:420)
        at java.awt.Frame.<init>(Frame.java:385)
        at javax.swing.JFrame.<init>(JFrame.java:180)
        at com.rapidminer.gui.tools.SplashScreen.<init>(SplashScreen.java:93)
        at com.rapidminer.gui.tools.SplashScreen.<init>(SplashScreen.java:106)
        at com.rapidminer.RapidMiner.showSplash(RapidMiner.java:558)
        at com.rapidminer.RapidMiner.showSplash(RapidMiner.java:554)
        at com.rapidminer.gui.RapidMinerGUI.run(RapidMinerGUI.java:212)
        at com.rapidminer.gui.RapidMinerGUI.launch(RapidMinerGUI.java:499)
        at com.rapidminer.gui.RapidMinerGUI.main(RapidMinerGUI.java:482)
        ... 5 more


not sure what I am looking at, but it doesn't match any docs or videos I can find. The video shows a GUI coming up and a nice clean prompt asking to create a repository- we're clearly miles from that here.

Can someone point me to docs that actually match what I am looking at, assuming this is even supported. Or next steps. Or something? Was there something in the setup or system requirements I missed????? Completely flummoxed as to how to proceed.

Thanks.

Answers

  • haddockhaddock Member Posts: 849  Maven
    Hi there,

    In the 'scripts' directory you can also try opening and executing 'rapidminerGui'. It works for me under Ubuntu and is referred to in 'install.txt'. Easy when you know how!

    Happy mining!
  • momnotmommomnotmom Member Posts: 2 Contributor I
    OK, thanks. That didn't work either, but I noticed that $DISPLAY was not being set when I Putty'ed in. I tried reinstalling xauth

    yum install xauth

    and it ended up upgrading xauth, and then everythging seems to work- at least when I start RapidMinerGUI it is prompting me to set up the initial repository.

    Thanks again for your encouragement.

  • haddockhaddock Member Posts: 849  Maven
    G'Day!

    I feel I owe you an apology, I didn't read your post in enough detail; mea maxima culpa , it was a long day! X marked a spot for me also last week, when a kernel update overwrote my NVIDIA drivers, leaving me window-less. What a treat!

    Anyways, sorry  ;D
Sign In or Register to comment.