issues of installing R-extension

huaiyanggongzihuaiyanggongzi Member Posts: 39 Contributor II
edited July 2019 in Help
I followed the R-extension installation guide step-by-step,  except the following step,
“Now you can configure RapidMiner. If you click on Next, you will be asked to enter the path to the jri library that has been installed with rJava. This is located in one of the .libpath directories noted above and more exact in <libpath directory>/rJava/jri/. The filename depends on your operating system and is jri.dll on Windows and libjri.so or jri.so on Unix.”

After clicking next, I selected C:\users\suc\Documents\R\win-library\2.15\rJava\jri\jri.dll
I think it should have been C:\users\suc\Documents\R\win-library\2.15\rJava\jri\jri.dll

But looks like there is no way to allow me modify it. I tried to re-install RapidMiner, removing R-extension and re-install R-extension. No matter what I did, it seems that the system just remember this. After I click next, the popup message box always says: Found library in C:\users\suc\Documents\R\win-library\2.15\rJava\jri\jri.dll


  • Options
    MariusHelfMariusHelf RapidMiner Certified Expert, Member Posts: 1,869 Unicorn

    you can edit the settings in Tools->Preferences->R

    Please note that the R architecture must match the RapidMiner architecture, so if you are using 64bit-RapidMiner, you have to choose the 64bit version of rJava. For me it's for example C:\Users\marius\Documents\R\win-library\2.15\rJava\jri\x64\jri.dll

    Best, Marius
Sign In or Register to comment.