🦉🦉   WOOT WOOT!   RAPIDMINER WISDOM 2020 EARLY BIRD REGISTRATION ENDS FRIDAY DEC 13!   REGISTER NOW!   🦉🦉

[SOLVED] Filter Examples Operator

RLynxRLynx Member Posts: 18  Maven
edited November 2018 in Help
Filter Examples operator does not work anymore for filtering (real and integer) missing values, but it works for missing nominal values.
Here is an example:

<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<process version="5.2.008">
 <context>
   <input/>
   <output/>
   <macros/>
 </context>
 <operator activated="true" class="process" compatibility="5.2.008" expanded="true" name="Process">
   <process expanded="true" height="476" width="748">
     <operator activated="true" class="retrieve" compatibility="5.2.008" expanded="true" height="60" name="Retrieve" width="90" x="112" y="75">
       <parameter key="repository_entry" value="//Samples/data/Labor-Negotiations"/>
     </operator>
     <operator activated="true" class="filter_examples" compatibility="5.2.008" expanded="true" height="76" name="Filter Missing Duration" width="90" x="246" y="75">
       <parameter key="condition_class" value="attribute_value_filter"/>
       <parameter key="parameter_string" value="duration = ?"/>
       <parameter key="invert_filter" value="true"/>
     </operator>
     <operator activated="true" class="filter_examples" compatibility="5.2.008" expanded="true" height="76" name="Filter Missing Vacation" width="90" x="380" y="75">
       <parameter key="condition_class" value="attribute_value_filter"/>
       <parameter key="parameter_string" value="vacation = \?"/>
       <parameter key="invert_filter" value="true"/>
     </operator>
     <connect from_op="Retrieve" from_port="output" to_op="Filter Missing Duration" to_port="example set input"/>
     <connect from_op="Filter Missing Duration" from_port="example set output" to_op="Filter Missing Vacation" to_port="example set input"/>
     <connect from_op="Filter Missing Vacation" from_port="example set output" to_port="result 1"/>
     <portSpacing port="source_input 1" spacing="0"/>
     <portSpacing port="sink_result 1" spacing="0"/>
     <portSpacing port="sink_result 2" spacing="0"/>
   </process>
 </operator>
</process>
Do I miss something? It used to work just fine before... Thank you!

Answers

  • Nils_WoehlerNils_Woehler Member Posts: 463  Guru
    Hi,

    unfortunately there seems to be a bug in the current version. We have fixed it and will release a bugfix version soon.

    Best,
    Nils
  • Nils_WoehlerNils_Woehler Member Posts: 463  Guru
    Hi,

    here is a workaround for you until we have released the fixed version:

    <?xml version="1.0" encoding="UTF-8" standalone="no"?>
    <process version="5.2.009">
     <context>
       <input/>
       <output/>
       <macros/>
     </context>
     <operator activated="true" class="process" compatibility="5.2.009" expanded="true" name="Process">
       <process expanded="true" height="269" width="681">
         <operator activated="true" class="retrieve" compatibility="5.2.009" expanded="true" height="60" name="Retrieve" width="90" x="121" y="149">
           <parameter key="repository_entry" value="//Samples/data/Labor-Negotiations"/>
         </operator>
         <operator activated="true" class="generate_attributes" compatibility="5.2.009" expanded="true" height="76" name="Generate Attributes" width="90" x="313" y="165">
           <list key="function_descriptions">
             <parameter key="duration_missing" value="missing(duration)"/>
           </list>
         </operator>
         <operator activated="true" class="filter_examples" compatibility="5.2.009" expanded="true" height="76" name="Filter Examples" width="90" x="447" y="165">
           <parameter key="condition_class" value="attribute_value_filter"/>
           <parameter key="parameter_string" value="duration_missing = false"/>
         </operator>
         <operator activated="true" class="select_attributes" compatibility="5.2.009" expanded="true" height="76" name="Select Attributes" width="90" x="581" y="165">
           <parameter key="attribute_filter_type" value="single"/>
           <parameter key="attribute" value="duration_missing"/>
           <parameter key="invert_selection" value="true"/>
         </operator>
         <connect from_op="Retrieve" from_port="output" to_op="Generate Attributes" to_port="example set input"/>
         <connect from_op="Generate Attributes" from_port="example set output" to_op="Filter Examples" to_port="example set input"/>
         <connect from_op="Filter Examples" from_port="example set output" to_op="Select Attributes" to_port="example set input"/>
         <connect from_op="Select Attributes" from_port="example set output" to_port="result 1"/>
         <portSpacing port="source_input 1" spacing="0"/>
         <portSpacing port="sink_result 1" spacing="0"/>
         <portSpacing port="sink_result 2" spacing="0"/>
       </process>
     </operator>
    </process>
    Best,
    Nils
  • RLynxRLynx Member Posts: 18  Maven
    Thank you for a nice workaround!

    Will wait for a new release.

Sign In or Register to comment.