Options

R extension activation problem

rkbukowsrkbukows Member Posts: 5 Contributor II
I am new to RapidMiner and since installarion I cannot activate R extension. All other extensions are fine.  When I attempt to activate R extension I first receive message "Found library in C:\Progrem Files\R|R-2.15.2\library\rJava\jri\jri.dll" then "The local binary library C:\Progrem Files\R|R-2.15.2\library\rJava\jri\jri.dll could not be loaded. Reason: C:\Progrem Files\R|R-2.15.2\library\rJava\jri\jri.dll: Can't find dependent libraries.

I removed old versions and installed new R, Java and RapidMiner. Still the same issue. I am running Windows 7 64 bit version and those are the versions of Java and R that I downloaded.

I would appreciate any help in that matter.

Radek

Answers

  • Options
    Nils_WoehlerNils_Woehler Member Posts: 463 Maven
    Hi Radek,

    it seems as if your PATH or R_HOME environment variable is wrong. Please check if they are set correctly.
    Or wait just a few more days. We are going to release  a new version of the R extension with improved install instructions in the near future.

    Best,
    Nils
  • Options
    rkbukowsrkbukows Member Posts: 5 Contributor II
    Many thanks. I tried to tweak the environment variables quite a bit (got even IT people to look at it). I will wait for the extension update. Would it requite to redownload the RapidMiner?

    Best

    Radek
  • Options
    Nils_WoehlerNils_Woehler Member Posts: 463 Maven
    Hi,

    the R extension 5.3 has been released. You can update your current extension in the menu bar 'Help>Updates'. I hope the improved install instructions help to install the R extension correctly on your machine.

    Best,
    Nils
  • Options
    heiyanheiyan Member Posts: 2 Contributor I
    Hello,

    I've always been an R user and I just started exploring Rapidminer over the past weekend and I'm super excited about the possibility of integrating the two.  Unfortunately, I am encountering the same issues with loading native libraries.  I have tried all suggestions in all related posts I could find but still get this error message:  "C:\Users\Angela\Documents\R\win-library\2.15\rJava\jri\x64\jri.dll: Can't find dependent libraries."

    I have tried re-installing R/Rapidminer/Java and still no luck.  I'm running Windows 8 64 bit, R 2.15.2 64 bit, Rapidminer 2.3.005 64bit, R Extension 5.3.0.  I believe I have followed all steps in the latest R installation assistant.  Below are my environment variable setting:
    ALLUSERSPROFILE=C:\ProgramData
    APPDATA=C:\Users\Angela\AppData\Roaming
    CommonProgramFiles=C:\Program Files\Common Files
    CommonProgramFiles(x86)=C:\Program Files (x86)\Common Files
    CommonProgramW6432=C:\Program Files\Common Files
    COMPUTERNAME=HEIYAN-YOGA
    ComSpec=C:\windows\system32\cmd.exe
    configsetroot=C:\windows\ConfigSetRoot
    FP_NO_HOST_CHECK=NO
    HOMEDRIVE=C:
    HOMEPATH=\Users\Angela
    JAVA_HOME=C:\Program Files\Java\jre7
    LOCALAPPDATA=C:\Users\Angela\AppData\Local
    LOGONSERVER=\\MicrosoftAccount
    NUMBER_OF_PROCESSORS=4
    OS=Windows_NT
    PATH=C:\Program Files (x86)\Intel\iCLS Client\;C:\Program Files\Intel\iCLS Client\;C:\windows\system32;C:\windows;C:\windows\System32\Wbem;C:\windows\System32\WindowsPowerShell\v1.0\;C:\Program Files\Intel\Intel(R) Management Engine Components\DAL;C:\Program Files\Intel\Intel(R) Management Engine Components\IPT;C:\Program Files (x86)\Intel\Intel(R) Management Engine Components\DAL;C:\Program Files (x86)\Intel\Intel(R) Management Engine Components\IPT;C:\Program Files (x86)\Intel\OpenCL SDK\2.0\bin\x86;C:\Program Files (x86)\Intel\OpenCL SDK\2.0\bin\x64; C:\Program Files\R\R-2.15.2\bin\x64
    PATHEXT=.COM;.EXE;.BAT;.CMD;.VBS;.VBE;.JS;.JSE;.WSF;.WSH;.MSC
    PROCESSOR_ARCHITECTURE=AMD64
    PROCESSOR_IDENTIFIER=Intel64 Family 6 Model 58 Stepping 9, GenuineIntel
    PROCESSOR_LEVEL=6
    PROCESSOR_REVISION=3a09
    ProgramData=C:\ProgramData
    ProgramFiles=C:\Program Files
    ProgramFiles(x86)=C:\Program Files (x86)
    ProgramW6432=C:\Program Files
    PROMPT=$P$G
    PSModulePath=C:\windows\system32\WindowsPowerShell\v1.0\Modules\
    PUBLIC=C:\Users\Public
    R_HOME=C:\Program Files\R\R-2.15.2
    SESSIONNAME=Console
    SystemDrive=C:
    SystemRoot=C:\windows
    TEMP=C:\Users\Angela\AppData\Local\Temp
    TMP=C:\Users\Angela\AppData\Local\Temp
    USERDOMAIN=HEIYAN-YOGA
    USERDOMAIN_ROAMINGPROFILE=HEIYAN-YOGA
    USERNAME=Angela
    USERPROFILE=C:\Users\Angela
    windir=C:\windows
    I have also tried adding these to my PATH:
    C:\Users\Angela\Documents\R\win-library\2.15\rJava\jri\x64
    C:\Program Files\Java\jre7\bin
    Or different combinations of them, and restarting, etc...  But it just won't work.  Can anyone kindly guide to to the right direction, please?

    Thank you so much!

    - Angela
  • Options
    Nils_WoehlerNils_Woehler Member Posts: 463 Maven
    Hi Angela,

    could you please try to remove the space in your PATH variable after the semicolon following OpenCL and bevore R (C:\Program Files (x86)\Intel\OpenCL SDK\2.0\bin\x64; C:\Program Files\R\R-2.15.2\bin\x64)? Otherwise your setup looks fine.

    Best,
    Nils
  • Options
    johan_CGjohan_CG Member Posts: 19 Contributor II
    Hi everyone,

    I had a problem to activate R extension and I read a lot of post to help me solve my problem. After many weeks of pain I succeeded to activate the R extension then I decided to write an index card to help others so I post it and I hope it will help you.

    Johan



    How to install R extension of RapidMiner on Windons 64 bits
    02/01/2013

    Requied : I. Windows configuration
    You have to set environment variables on Windows.
    • If it does not exist, create a JAVA_HOME environment variable for the 64 bits installation folder of Java. It must point to the jre folder. In my case it is located at : [glow=black,2,300]C:\Program Files\Java\jre7[/glow]
    • Create a R_HOME environment variable for the installation folder. It must point the folder with the version number. In my case it is : [glow=black,2,300]C:\Program Files\R\R-2.15.2[/glow]
    • Add the following address to the PATH:
      • The bin folder of Java located at : [glow=black,2,300]%JAVA_HOME%\bin[/glow]
      • The jvm.dll library of Java located at : [glow=black,2,300]%JAVA_HOME%\bin\server[/glow]
      • The R 64 bits executable located at : [glow=black,2,300]%R_HOME%\bin\x64[/glow]
      • The R libraries folder located at : [glow=black,2,300]%R_HOME%\library[/glow]
      • The R native libraries folder located at : [glow=black,2,300]%R_HOME%\include[/glow]
    II. R configuration
    When the environment variables are set, you can prepare R for the connection with RapidMiner.
    You have to download rJava package which is the connector between R and Java applications. You can use the following commands to do it:
    • Download and install the rJava package: [glow=black,2,300]install.packages("rJava")[/glow]
    • Display the package installed folder: [glow=black,2,300].libPaths()[/glow]
    III. RapidMiner Configuration
    Now you are ready to connect the R extension.

    Download the RapidMiner R extension with the package manager of RapidMiner. When the extension is installed RapidMiner need to restart in order the change take effect. After the restart you have a window to configure the R extension. The window explains in a tricky way the configuration. If you have followed rightly this document you don’t need to read the instruction in this window and click “Next”.

    At the bottom of the window you must have a new button “Select jri.dll” or something like that. The jri.dll file is located in the rJava folder located at the address display by the R command .libPaths(). For me it is located at: [glow=black,2,300]C:\Program Files\R\R-2.15.2\library\rJava\jri\x64[/glow].You have a jri.dll in the rJava but don’t take this one. You must choose the one which is in the x64 folder.

    If you can see the R view in your RapidMiner environment, the installation is succeed.
    In case you have an error like a problem with a 32 bits jri on the 64 bits platform, remove jri.dll in [glow=black,2,300]C:\Program Files\R\R-2.15.2\library\rJava\jri[/glow] and point RapidMiner to the x64 folder.
  • Options
    heiyanheiyan Member Posts: 2 Contributor I
    Hi Nils - Removing the space did it!  I can't believe how easy it is once you pointed it out!  Thank you so much!!
    Hi Johan - Thank you for the very detailed description, I'm sure this will help anyone in the future with installation question.
  • Options
    AmirJamezAmirJamez Member Posts: 5 Contributor II
    @johan_CG, thanks for the informative post, Have u ever integrated the two in linux as well ? I am still trying to find it out.

    Best,

    Amir
  • Options
    johan_CGjohan_CG Member Posts: 19 Contributor II
    @Angela : You welcome  ;). I think it can be a good idea if they specify in the documentation to be cautious with the space and special caracters like quote in the environment variables because me too I was blocked a long time with the PATH.

    @ Amir : My pleasure for the post ;). I tried one time to install it on a Linux virtual machine. I follow the RapidMiner documentation and it worked only once and as I succeed to install it on Windows I didn't try again.
    What is your problem? Do you have an error message?

    Johan
Sign In or Register to comment.