🥳 RAPIDMINER 9.9 IS OUT!!! 🥳

The updates in 9.9 power advanced use cases and offer productivity enhancements for users who prefer to code.

CLICK HERE TO DOWNLOAD

[SOLVED] Trying to run RapidMiner Unuk in Eclipse

j0kerj0ker Member Posts: 5 Contributor II
edited November 2018 in Help
Hello!

I'm trying to implement operator, but I can't even build the source code of Unuk rev: 820.
I've followed these instructions: http://rapid-i.com/content/view/25/27/lang,en/

My configuration:
Ubuntu12.10
window->pref->installed jre: /usr/lib/jvm/java-7-openjdk-i386/jre
project:
      - jre-system-library: java-7-openjdk-i386
      - compiler-> compliance level: 1.7
      - project facets->java: 1.7

ant build... : "clean, copy-resources, build, createJar"

I have only warnings on the Eclipse's "Markers" tab like:
"/RapidMiner_Unuk/lib/blas.jar will not be exported or published. Runtime ClassNotFoundExceptions may result."
Although I've already set them on Java build path.

I have 84 errors after building the code.

What cause the problem?
(I have to use jre7)

Thanks in advance,
Balazs Varhegyi
Tagged:

Answers

  • j0kerj0ker Member Posts: 5 Contributor II
    I think part of the problem was the com.rapidminer.doc package, because I've deleted and 70 error disappeared, but I still have 14.
  • Marco_BoeckMarco_Boeck Team Lead Software Engineering Administrator, Moderator, Employee, Member, University Professor Posts: 1,958   RM Engineering
    Hi,

    please note that the SVN has moved: see here.
    Also we do use Oracle Java7 (Sun JVM), however we currently still compile against Java6, so you might want to do that as well.

    Regards,
    Marco
  • j0kerj0ker Member Posts: 5 Contributor II
    Thanks for the reply!

    Finally I was able to compile it. I had to comment out some stuff from SQLQueryBuilder.java. I don't want to use it, so it might not a problem. It said "cannot find symbol", when I tried to attach source to them It tried to load it from rt.jar (from open-jdk's lib) So I suppose the different jdks caused the problem. If other problem will occur I will follow the instructions you gave.

    Kind regards,
    Balazs
  • RaedMarjiRaedMarji Member Posts: 13 Contributor II
    I recommend you update your java to oracle's version 6 or 7 will do the trick, also you need to run install target when you want to test your operators. make sure yo fix the build xml file in the template code before you try to run it. I fyou need anything else dont hesitate to ask
    raed
Sign In or Register to comment.