RapidAnalytics Oracle Insatllation problems

carnycarny Member Posts: 1 Contributor I
edited November 2018 in Help
I am trying to install RapidAnalytics onto a Windows server, I have successfully install RapidMiner but am having problems with RapidAnalytics, below are the step I have performed:-

The server is running windows 2003 and has Java JRE 1.6.0_24
Download and unzip the installer 1.3.008
Create Database User called rapidanalytics
Copy oracle driver, ojdbc6.jar, to the unzipped loaction of the installer (data\jdbc)
Run RapidAnalytics-Insatller.bat, select location containing no spaces.
Work through the wizard, successfully test the database connection, Installation complete
Create database tables as per config\quartz\tables_oracle.sql
execute \bin\run.bat

When I try and log in (localhost:8080) it tells me that the password/unsername is wrong, i'm using admin/changeit
When I try and access localhost:8080\admin-console I get JBoss Web/3.0.0-CR1 - Error Report HTTP Status 404

I have tried this installtion a few times now and always the same problem, I have also tried creating a rapidanalytics-ds.xml
with the Oracle database details in it but it makes no difference.  Below are some of the errors from the boot.log and server.log

boot.log

10:30:16,953 ERROR [STDERR] SLF4J: Class path contains multiple SLF4J bindings. 10:30:16,984 ERROR [STDERR] SLF4J: Found binding in [vfs:/C:/RapidAnalytics/common/lib/slf4j-jboss-logmanager.jar/org/slf4j/impl/StaticLoggerBinder.class] 10:30:17,031 ERROR [STDERR] SLF4J: Found binding in [vfs:/C:/RapidAnalytics/server/default/lib/slf4j-simple-1.6.4.jar/org/slf4j/impl/StaticLoggerBinder.class] 10:30:17,093 ERROR [STDERR] SLF4J: See http://www.slf4j.org/codes.html#multiple_bindings for an explanation. 10:30:17,281 ERROR [STDERR] 78 [JBossWS-CXF-DefaultBus-Init] INFO org.jboss.wsf.stack.cxf.client.configuration.JBossWSBusApplicationContext - Refreshing org.jboss.[email protected]360771: startup date [Mon May 13 10:30:17 BST 2013]; root of context hierarchy 10:30:18,312 INFO  [JSFImplManagementDeployer] Initialized 4 JSF configurations: [Mojarra-2.1.7, Mojarra-1.2, MyFaces-2.0, Mojarra-2.0]
10:30:18,421 ERROR [STDERR] 1218 [JBossWS-CXF-DefaultBus-Init] INFO org.springframework.beans.factory.support.DefaultListableBeanFactory - Pre-instantiating singletons in org.s[email protected]4a85c5: defining beans []; root of factory hierarchy 10:30:18,546 ERROR [STDERR] 1343 [JBossWS-CXF-DefaultBus-Init] INFO

server.log

2013-05-13 10:34:12,156 INFO  [org.apache.coyote.http11.Http11Protocol] (Thread-2) Starting Coyote HTTP/1.1 on http-8080
2013-05-13 10:34:12,218 INFO  [org.apache.coyote.ajp.AjpProtocol] (Thread-2) Starting Coyote AJP/1.3 on ajp-127.0.0.1-8009
2013-05-13 10:34:12,265 INFO  [org.jboss.bootstrap.impl.base.server.AbstractServer] (Thread-2) JBossAS [6.0.0.Final "Neo"] Started in 4m:8s:922ms
2013-05-13 10:35:36,140 SEVERE [facelets.compiler] (http-8080-1) Error Loading Library: vfs:/C:/RapidAnalytics/server/default/deployers/jsf.deployer/Mojarra-2.1.7/jsf-libs/javax.faces-2.1.7.jar/com/sun/faces/metadata/taglib/jstl-fn.taglib.xml: java.io.IOException: Error parsing [vfs:/C:/RapidAnalytics/server/default/deployers/jsf.deployer/Mojarra-2.1.7/jsf-libs/javax.faces-2.1.7.jar/com/sun/faces/metadata/taglib/jstl-fn.taglib.xml]:
2013-05-13 10:35:36,640 WARNING [de.rapidanalytics.ejb.UserManagementEJBImpl] (http-8080-1) getCallerPrincipal() threw: java.lang.IllegalStateException: No valid security context for the caller identity
2013-05-13 10:35:36,640 WARNING [de.rapidanalytics.user.DefaultUserLookupService] (http-8080-1) User null is unknown and no anonymous user is registered. Using null user.
2013-05-13 10:35:36,687 ERROR [STDERR] (http-8080-1) 319484 [http-8080-1] WARN org.hibernate.util.JDBCExceptionReporter - SQL Error: 2289, SQLState: 42000 2013-05-13 10:35:36,687 ERROR [STDERR] (http-8080-1) 319484 [http-8080-1] ERROR org.hibernate.util.JDBCExceptionReporter - ORA-02289: sequence does not exist
2013-05-13 10:35:36,687 ERROR [STDERR] (http-8080-1)  2013-05-13 10:35:36,687 WARNING [de.rapidanalytics.ejb.AccessLogEJB] (http-8080-1) Failed to insert log record: javax.persistence.PersistenceException: org.hibernate.exception.SQLGrammarException: could not get next sequence value: javax.persistence.PersistenceException: org.hibernate.exception.SQLGrammarException: could not get next sequence value
Tagged:

Answers

  • Nils_WoehlerNils_Woehler Member Posts: 463  Guru
    Hi carny,

    your steps seem to be correct. Could you please post the complete boot.log from the first start after a fresh installation of RA?

    Best,
    Nils
Sign In or Register to comment.