"[SOLVED] R-scripts take too long to execute and RapidMiner starts up slowly"

balintkbalintk Member Posts: 5 Contributor II
edited June 2019 in Help

I've been using RapidMiner for quite a while and I recently downloaded the R-Extension. Yesterday it was working fine, but today RapidMiner took long to start up (hanging at "Initializing Plugin GUI" in splash screen for long) and the R-scripts in the "Execute Script" operators takes too long to execute (took only a second yesterday, now it takes approximately 2-3-4 minutes). I haven't done anything to that. It's so slow, that even a simple addition-script like this takes 2:48 minutes to execute:
sum_vec <- data[1] + data[2]

complete <- c(data, sum_vec)
result <- as.data.frame(complete)
colnames(result) = names(data)
colnames(result)[13] = "sum"
My setup is:

- Intel Core i7 Q720 1.6 Ghz (Quad core)
- 8 GB RAM
- Windows 7 64 bit Ultimate Edition
- RapidMiner 5.3.008
- R x64 3.0.1

I thoght the problem was, that my Windows and Java JRE7 were 64 bit, but RapidMiner 5.3.008 and R 3.0.1 were 32 bit. So I uninstalled and then reinstalled the 64 bit edition of RapidMiner and R. It didn't change anything.

I've searched the forum and Google, but couldn't find anything to this issue.

My system variables are:
JAVA_HOME = C:\Program Files\jre7
R_HOME = C:\Program Files\R\R-3.0.1
Path = %R_HOME%\bin\x64;C:\Program Files\R\R-3.0.1

Even looked into this guide, that's why there's two entries in my "Path"-variable:

And I copied "rJava" to the installation library of R, "C:\Program Files\R\R-3.0.1\library" from my Documents and Settings library after using "install.package("rJava")" in R. Also replaced the jri.dll in "C:\Program Files\R\R-3.0.1\library\rJava\jri" to the jri.dll from the "x64" folder.

Fortunately, the R console in RapidMiner works fine and the R command prompt works fine too.

It would be really helpful if at least I knew what caused this problem, because I'm using this for work.

Thank you,


UPDATE: I've uninstalled, deleted every RapidMiner files from my computer, reinstalled, and it's still not resolved. Even downloaded manually the .jar file of the extension and put into the lib/plugins library, it's still takes too long to execute R scripts. I checked it, every script was executed under 2:48 minutes.


  • Options
    balintkbalintk Member Posts: 5 Contributor II
    Somewhat temporary solution, however, it works perfectly now.

    I am using the 2.15.0 version of R and followed strictly the installing instructions for the R-Extension. That solved the issue.
Sign In or Register to comment.