Options

"Upgrade from 5.308 to 5.313 fails with no error"

AsokaAsoka Member Posts: 14 Contributor II
edited June 2019 in Help
I am trying to use the Updates and Extensions (Marketplace) option to upgrade extensions and Rapid Miner community edition.  The extensions all upgraded without issue.

When I try to upgrade from 5.3.008 to 5.3.013 of Rapid Miner though, the 22.1MB download runs, and I am then told that to apply the update, Rapid Miner needs to be restarted.  I choose Yes on that dialog box to restart Rapid Miner.

When it finishes restarting, it continues to indicate that I am on v5.3.008.  There is no error message or other indicator of failure - the version number fails to change (and I assume that the actual upgrade hasn't happened).

I'm running on Win 7 and pretty sure I have 64 bit RM installed (if that helps).

I have rebooted several times and retried the upgrade with the same result.

Any ideas?
Tagged:

Answers

  • Options
    RalfKlinkenbergRalfKlinkenberg Employee, RapidMiner Certified Analyst, RapidMiner Certified Expert, RMResearcher, Member, Unconfirmed, University Professor Posts: 68 RM Founder
    Hello Asoka,

    have you tried to start RapidMiner with administrator rights?

    You can do so by right clicking on the RapidMiner icon on the desktop and choosing "Start with administrator rights". This may be necessary on some systems, because the update needs to write to the installation directory of RapidMiner, which may require administrator rights.

    Best wishes,
    Ralf
  • Options
    AsokaAsoka Member Posts: 14 Contributor II
    Good thought Ralf - I haven't tried that previously, but just did so and I get the same result (the upgrade process all looks happy, but when RM restarts, I'm still on 5.3.008 according to the title bar).
  • Options
    Marco_BoeckMarco_Boeck Administrator, Moderator, Employee, Member, University Professor Posts: 1,996 RM Engineering
    Hi,

    strange. When not starting RapidMiner with admin priviliges, the Windows UAC popup should appear asking for admin credentials when RapidMiner restarts. Just tested it on different RM installations in different directories and works fine for me.. We'll have a  look into it.
    To solve your issue though you can update without using the update manager - just download the latest RM version for example here: http://sourceforge.net/projects/rapidminer/files/1. RapidMiner/5.3/ and install it in the same directory. Unless you have placed your RapidMiner repository in the same folder as your RM installation, no data loss will occur. If you did, just backup your repository folder and then install the new RM version. Also all settings are stored in the home/.RapidMiner5 folder which is not deleted/changed when installing/uninstalling RapidMiner.

    Regards,
    Marco
Sign In or Register to comment.