Options

"storing csv file data in database using Rapidminer"

RamanRaman Member Posts: 8 Contributor II
edited June 2019 in Help
I want to store CSV file content in MYSQL database using Rapidminer. But the problem is -
Database error occured: attribute reviewText contains values with length>255 which is the maximum length for columns of SQL type VARCHAR.
and i also checked the set default varchar length. But it does not resolve my problem.
Tagged:

Answers

  • Options
    Marco_BoeckMarco_Boeck Administrator, Moderator, Employee, Member, University Professor Posts: 1,996 RM Engineering
    Hi,

    you have 2 options: Either during import change the column type to "text" or use the "Nominal to Text" operator before your "Write Database" operator. In both cases the resulting SQL column will be of a TEXT type.

    Regards,
    Marco
  • Options
    RamanRaman Member Posts: 8 Contributor II
    [SOLVED ] thank you so much Sir... It works.
Sign In or Register to comment.