Options

Fails to start in Windows 8, Windows 7

robert99robert99 Member Posts: 15 Contributor II
edited November 2018 in Help
RapidMiner 5.3.013 32 bit
Latest Java

I have read the similar thread for Windows XP at
http://rapid-i.com/rapidforum/index.php/topic,7119.0.html

My Windows 7, 4Gb RAM, 32 bit laptop will only start RapidMiner from RapidMinerGUI.bat.
The normal Windows icon does nothing.

My Windows 8 desktop machine is 64 bit, 8Gb RAM, but Java is installed as 32 bit as recommended by Java for reading browsers.
This does not start RapidMiner (32 bit version) from the Windows icon nor RapidMinerGUI.bat.
Nothing happens.

Answers

  • Options
    Marco_BoeckMarco_Boeck Administrator, Moderator, Employee, Member, University Professor Posts: 1,996 RM Engineering
    Hi,

    can you please try to start the RapidMinerGUI.bat from the commandline on both systems and post the respective output here?

    Regards,
    Marco
  • Options
    robert99robert99 Member Posts: 15 Contributor II
    Marco Boeck wrote:

    Hi,

    can you please try to start the RapidMinerGUI.bat from the commandline on both systems and post the respective output here?

    Regards,
    Marco
    Thankyou.

    I have solved the W8 problem by installing 64bit RapidMiner which runs on 32 bit Java.
    I then had to install 64 bit Java as well as 32 bit to get the R extension to run,


    Win 7 problem remains.
    I have attached the windows 7 command line output when I run RapidMinerGUI.bat

    "C:\Progran Files\Rapid—I\BapidMiner5\scripts>rapidninergui.bat
    RAPIDMINERHOME is not set. Trying the directory ‘c:\Program Files\Rapid—I\RapidMiner5\scripts\. .‘...
    Using local jre: c:\Program Files\Rapid—I\flapidMiner5\scripts\. .\jre\bin\java.exe
    Starting RapidMiner from ‘c:\Program Files\Rapid—I\RapidMiner5\scripts\..’ using classes from c:\Program Files\Rapid—I\RapidMiner5\scripts\. .\lib\rapidminer.jar
    Creating file “C:\Users\Robert\AppData\Roaming\check_rm...java_version’
    Java Version 1.7.0_11
    Removing file “C:\Users\Bobert\AppData\Roaming\check_rm...java_version’
    Starting in multicore mode with Cl garbage collector...
    Error occurred during initialization of UM
    Could not reserve enough space for object heap
    C:\Progran Files\Rapid—I\RapidMiner5\scripts>
    "

    image
  • Options
    robert99robert99 Member Posts: 15 Contributor II
    Any news on this as file data supplied?
  • Options
    Marco_BoeckMarco_Boeck Administrator, Moderator, Employee, Member, University Professor Posts: 1,996 RM Engineering
    Hi,

    java cannot allocate the memory it needs for some reason. That can either mean you are using most of the memory for other programs, so either there is not enough free memory overall, or there is not enough to allocate a contiguous block of memory. You can try to edit the RapidMinerGUI.bat file, and adjust the MAX_JAVA_MEMORY setting (sets the max memory java allocates in megabytes).

    Regards,
    Marco
  • Options
    robert99robert99 Member Posts: 15 Contributor II
    Thank you.

    I have tried to raise the default memory limit from 1024 Mb but access is denied when trying to save the altered file.
    I have tried renaming the bat file but get same result.

    My free memory resource is about 50% which is 1432 Mb.

    I cannot now get RapidMiner to run properly  even from the bat file. A shell window opens briefly then closes.
  • Options
    Marco_BoeckMarco_Boeck Administrator, Moderator, Employee, Member, University Professor Posts: 1,996 RM Engineering
    Hi,

    you probably have installed RapidMiner into C:\Program Files\xyz. To edit files in that directory, you need administrator privileges, as Windows will prevent you from doing so without them.

    Regards,
    Marco
  • Options
    robert99robert99 Member Posts: 15 Contributor II
    I have set Java max memory to 1024 Mb.

    Java only takes 364Mb when running.


    Problem remains unresolved.
Sign In or Register to comment.