Windows 10 - Scaling Issue

bball23bball23 Member Posts: 1 Contributor I
edited November 2018 in Help
Hi - since buying a new Lenovo ideapad Y700 w/ultra hd, I've been having some weird scaling issues with various software programs, including rapidminer.  See the screenshot below for the attachment.  I was able to email a couple of other software programs such as iObit to get fixes for this issue and I was wondering if anyone had a fix for rapidminer as well?

Basically, the program looks great (nice and crisp in Windows 10), but all of the text and things like "File," "Edit," etc. are so tiny and it almost makes the program impossible to use.

As a note, going into the .exe file and turning on "Disable display scaling on high DPI settings" did work for some applications (e.g., Spyware Blaster), but not rapidminer. :/

http://postimg.org/image/98lft2zt3/
omegianshyan_lawrence

Best Answer

  • shyan_lawrenceshyan_lawrence Posts: 1 Contributor I
    Solution Accepted

    So this solution worked for me on my Windows 10 device (Surface Pro 4):

    1. Go to Rapidminer Studio.exe properties (right click > Properties)

    2. Under the "Compatibility" tab check "Override high DPI scaling behaviour..." and set Scaling perfomed by  to "System"

    3. Click "OK"

Answers

  • Marco_BoeckMarco_Boeck Team Lead Software Engineering Administrator, Moderator, Employee, Member, University Professor Posts: 1,908   RM Engineering
    Hi,

    thank you for the report! We are aware of this issue but unfortunately there are a number of technical difficulties to overcome first.

    Regards,
    Marco
  • trod9691trod9691 Member Posts: 1 Contributor I
    Hello,

    Was wondering if there was a solution to this problem? I'm running Windows 10 on a 4k resolution screen and am running into the same problem, the font in the UI is unreadable due to its size.

    Thank you,
    Tony
  • JEdwardJEdward RapidMiner Certified Analyst, RapidMiner Certified Expert, Member Posts: 564   Unicorn
    One thing you might try (this is a bit of a hack) is download a font editor & the RM UI fonts from github.  Then edit the fonts to change the EM size to a higher value. 
    Save them & install in your PC.  Now when you start RapidMiner you'll be using customized fonts especially for you setup. 
  • HenningHenning Member Posts: 1 Contributor I

    Hello Rapidminer Team,

    are there any news on this issue?

    I'm struggeling with this also since months.

     

    I'm travelling a lot and would like to use RM Studio in the train on my notebook with HiRes, but it's simply unusable.

    Everything's appearing very tiny on the screen.

     

    The workaround mentioned above doesn't work for me.

    Could you pls. put this topic on prio? It is reported since ~6months now.

    This is putting a little shadow on the great tool Rapidminer!

     

    Thanks!

  • alexeyalexey Member Posts: 1 Contributor I

    See EDIT2 of this answer, it helped me. I opened this file C:\Program Files\RapidMiner\RapidMiner Studio\jre\bin\javaw.exe in ResTuner and edited Manifest, replacing <dpiAware>true</dpiAware> with <dpiAware>false</dpiAware>

    te_141360mldavis
  • bjserpasbjserpas Member Posts: 1 Contributor I

    This solution does not work with the current version of RapidMiner Studio (7.2.2). I've used this solution many times for other Java apps, and it was fine. By setting the 'dpiaware' setting to 'false,' just about every Java app I've tried scales properly. Unfortunately, I cannot get RapidMiner to do the same. I am even running it from the command line to ensure that RapidMiner is using the local jre folder (and not the global system folder), but I still can't get it to scale.

     

    I'm running Windows 10. Is there a workaround for this? Or perhaps a version of RapidMiner that this solution works with?

     

    Apologies, my issue was due to the very bizarre way in which Resource Tuner caches files that are administrator-protected, even if opened as an administrator. Moving the executables out of Program Files, modifying them, and then copying them back works fine.


    Still, this is in no way an ideal solution, and I am amazed that there is still no official fix from the development team from this, after months of the community asking for it. Hopefully we will see one in the near future.

  • zprekopcsakzprekopcsak RapidMiner Certified Expert, Member Posts: 47  Guru

    Hi All,

     

    The challenge is that different operating systems and different Java versions have completely different behaviour in terms of high-resolution support. We are working on this and we will release an improved version and a dedicated documentation page on this topic in the next few months.

     

    Best,

    hmd_nasrphoenixlin70
  • marcos_orregomarcos_orrego Member Posts: 1 Contributor I

    i must say that changing the manifest highdpi from true to false does nothing.

     

    any news on any workaround?

    hmd_nasr
  • hmd_nasrhmd_nasr Member Posts: 2 Contributor I

    hi everybody, I recently learnt the rapidminer and downoaded it, my laptop in FHD and when I opened it, I was amazed of the size of fonts, icons, bottons, ....  . ALL OF THEM ARE EXTEREMELY SMALL, I get eye strain.:smileymad:

    Dear rapidminer team the software is wonderful :smileyhappy:, but please solve this issue and make all the things really bigger. put a scale in the software to choose from. even I reduced the resolution and put the scaling to 175% in windows, it is still small, Im happy that I have not bought a 4k monitor, that way the software would be absoloutly useless.:smileyfrustrated:

  • zprekopcsakzprekopcsak RapidMiner Certified Expert, Member Posts: 47  Guru

    Please try the recently released RapidMiner Studio 7.3 and follow this documentation page according to your operating system:

    http://docs.rapidminer.com/studio/installation/hidpi.html

    Please report if it did or did not resolve your problem with high-resolution displays.

    Thanks, Zoltan

    Vorty
  • mskinnermskinner Member Posts: 10 Contributor I

    it did not work 

     

    the final step could not be performed 

    1. Finally you will need to adjust the scaling via your display settings. Go to Control Panel > Appearance and Personalization > Display and run RapidMiner Studio. It should now be displayed with a scaling that fits your high DPI resolution.

    the options under control panel were notavailable in win 7 enterprise

  • dwolfdwolf Member Posts: 1 Contributor I
    Recently purchased a new laptop ( ASUS GL552VW running Window 10 home) and after downloading and installing the latest version of RapiMiner Studio I am having the same scaling issue. I have attempted all the suggested fixes with either no or minimal affect. I have come to really appreciate the power of Rapidminer and would very much like to keep it as my primary anylytical tool. However it is presently unusable for me. Please let me know when there is a fix.
  • Marco_BoeckMarco_Boeck Team Lead Software Engineering Administrator, Moderator, Employee, Member, University Professor Posts: 1,908   RM Engineering

    Hi,

     

    can you describe your exact problem? Because all I need to do on my machine is right-click on my Desktop, go to Display Settings, and then move the slider to the right.

     

    1.png

     

    Regards,

    Marco

  • zprekopcsakzprekopcsak RapidMiner Certified Expert, Member Posts: 47  Guru

    @mskinner: Are you sure that the mentioned pre-requisites are satisfied?

     

    http://docs.rapidminer.com/studio/installation/hidpi.html

    In Windows 7 platforms there are two prerequisites for the scaling adjustment to take effect:

    • You are using an Aero Theme. To check which theme you are currently using, go to Control Panel >Appearance and Personalization > Personalization and make sure to choose a theme under theAero Themes section.
    • You are not using Windows XP DPI scaling. To make sure this is the case, please go to Control Panel> Appearance and Personalization > Display > Set custom text size(DPI) and make sure that Use Windows XP Style DPI scaling is not checked.
  • VortyVorty Member Posts: 3 Contributor I

    In reply to Zoltan's post, I just wanted to mention that I followed the steps explained for Windows 7/8.x (involving editing the java.exe and javaw.exe manifests) on my Windows 10 Home edition and it worked just fine. It is actually much better than the Windows 10 solution which involves changing the Display settings, as it requires to be pushed to 300% to have a significant impact, and at this value it messes up a lot of other elements outside RapidMiner.

    mschmitzzprekopcsak
  • mldavismldavis Member Posts: 1 Contributor I

    This solution worked perfectly with RapidMiner Studio 7.3 on Microsoft Surface Book.  The Win10 scaling solution provided by RapidMiner is much less desireable.  Thank you alexy.Re:

     

    "Windows 10 - Scaling Issue [ New ]


    See EDIT2 of this answer, it helped me. I opened this file C:\Program Files\RapidMiner\RapidMiner Studio\jre\bin\javaw.exe in ResTuner and edited Manifest, replacing <dpiAware>true</dpiAware> with <dpiAware>false</dpiAware> "


  • ngeorgengeorge Member Posts: 2 Contributor I

    I'm incredulous that this can this is an issue for something released over a decade ago.  I'm completely baffled there's not a simple option under 'View' for globally enlarging the font.  Following @mldavis 's solution (editing the manifest with Resource Tuner) worked on Windows 7.  You guys should probably change that line of code in your next release.

  • Marco_BoeckMarco_Boeck Team Lead Software Engineering Administrator, Moderator, Employee, Member, University Professor Posts: 1,908   RM Engineering

    Hi,

     

    unfortunately, the whole scaling business across platforms and different OS versions for those platforms is not as trivial as it may look from the outside. There are lots of problems associated with it, which is why it's the way it is currently.

     

    Some technical details for the interested:

    - We provide the "-Dsun.java2d.dpiaware=false" switch when launching RapidMiner Studio, but it does not work everywhere.

    - Editing the manifest of the javaw.exe is something we are not allowed to by the legal framework of Java. We cannot edit the file and ship a modified JRE or Oracle could come after us. Only endusers may alter the file once they have installed Studio. Which is why this is detailed in our docs: http://docs.rapidminer.com/studio/installation/hidpi.html

     

    Regards,

    Marco

    Thomas_Ott
  • frauke_jauchfrauke_jauch Member Posts: 1 Contributor I

    Where do you activate "scaling by system"?

    I can check "Override high DPI scaling behaviour..." box but cannot find scaling by system.

    In my view I need to chose the system and Windows 10 is not available (only until 8)...

  • Thomas_OttThomas_Ott RapidMiner Certified Analyst, RapidMiner Certified Expert, Member Posts: 1,761   Unicorn

    It's probably best to ping @shyan_lawrence if you're using a Surface Pro

  • hfrankehfranke Member Posts: 2 Contributor I

    Thomas,

     


    @Thomas_Ott wrote:

    It's probably best to ping @shyan_lawrence if you're using a Surface Pro


    you mean that you as the vendor of RM don't give support on such crucial questions?

    Personally, I switched to KNIME when I realized that my questions are not answered when I raised my scaling-problem and no solution was delivered. I'm using a Surface Book with 2 x 4K monitors.

    Sad, but KNIME doesn't have this problem.

  • Thomas_OttThomas_Ott RapidMiner Certified Analyst, RapidMiner Certified Expert, Member Posts: 1,761   Unicorn

    Hi Franke,

     

    I don't want to get into a RapidMiner vs Knime pissing match here. Our development group has informed me that there are only workarounds available to this problem until Java 9 comes up with true HDP support. I'm not sure how KNIME is handling it but we have issued some possible workarounds in the meantime. I'm sorry it didn't work for you but we'll welcome you back to the RapidMiner family when it's fixed. 

    phellinger
  • omar_moralesgomar_moralesg Member Posts: 1 Contributor I

    I am not being able to solve the issue with this solution or neither the  one provided as a native windows 10 solution, still see only rapidminer with small fonts, all other applications are well scaled. 

     

Sign In or Register to comment.