Options

RM install on 64 bit Win8/VMware/Fusion on Mac - hangs on Loading GUI Properties

quinn47quinn47 Member Posts: 2 Contributor I
edited June 2019 in Help
I am having the exact same problem as a previous poster (who got no answer)

I am running Windows 8 under VMware Fusion 5.
The problems include-
I would love to have RM install on the Mac side of things, but every time I try to install it, it insists on installing it on the Windows side (even if I have Fusion closed.) Anyone know how to make that happen (ins all RM on Mac side when Fusion is present?)

Installed on the Windows side, It was insisting on setting RAPIDMINER_HOME to Shaed_Folder on the Mac. I managed to get that taken care of (I think) by jiggering up rapid miner.bat to see it. It was not clear even after that, that it was getting it set. I next reworked a rapidminer.jar file (using java -D) to try to get java to get the RM home dir correct. That has solved the ERRORs associated with the HOME -- until, it tried to open a file -- then it is again insisting on going to the Shared Folder and fails again.

By default, you're not allowed to edit the permissions on that folder (good) - because opening it to writes from Windows is a good way to get an infection.

I am just exasperated.
Does anyone know how to resolve this?
I am happy to uninstall and start over if someone knows how to get either of:
1) RM installed on the Mac side with VMware Fusion present on the machine
2) Get the install to Windows 8 to run.
I would prefer not to have RAPIDMINER_HOME set to that Shared Folder, but rather to C:Program Files\Rapid-I\RapidMiner5

Thank you.  -Pat


---------------
b2013 wrote:

I have installed RapidMIner into Windows 7 via VMware Fusion on my MacBook. Unfortunately, I can't get it to start up and it gets stuck at "Loading GUI Properties".

Please help!

Answers

  • Options
    quinn47quinn47 Member Posts: 2 Contributor I
    Is there no one who is able to help with this?
    I am unable to get RM to launch?

    Thanks    -Pat
  • Options
    Marco_BoeckMarco_Boeck Administrator, Moderator, Employee, Member, University Professor Posts: 1,996 RM Engineering
    Hi,

    I have never used Fusion, so I'm not quite sure what the problem is. What happens when you unzip the platform independant version in a folder on the Mac side of things and just run the RapidMinerGUI.sh file? (Btw, RapidMiner Studio 6 comes with greatly improved Mac support including .app).
    If you want to install it on Windows, you can set an environment variable called "rapidminer.home" to point to the folder you want which then should be used by RapidMiner.

    Regards,
    Marco
Sign In or Register to comment.