RapidMiner 9.7 is Now Available

Lots of amazing new improvements including true version control! Learn more about what's new here.

CLICK HERE TO DOWNLOAD

"split operator - export data not complete for further use/operators"

joeijoei Member Posts: 6 Contributor I
edited June 2019 in Help
Hello,

the split operator gives only the first three split columns to the next operator even if it created more. That means that in the result view everything is fine but if I want to choose more than the first three split columns in the next operator it is not possible, they are not visible.

Here a simple table:
bla     split
asdf   2345x2134
dsaf   2345x2345x345x456x356x3546
sadf   2435x2345

They are 6 split columns (splitting with x) created but one only can choose the first three.
Here the code:
<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<process version="5.3.013">
  <context>
    <input/>
    <output/>
    <macros/>
  </context>
  <operator activated="true" class="process" compatibility="5.3.013" expanded="true" name="Process">
    <process expanded="true">
      <operator activated="true" class="read_excel" compatibility="5.3.013" expanded="true" height="60" name="Read Excel" width="90" x="45" y="75">
        <parameter key="excel_file" value="C:\Users\FIXCSHW\Documents\Test\rapidminer_split_text.xlsx"/>
        <parameter key="imported_cell_range" value="A1:B4"/>
        <parameter key="first_row_as_names" value="false"/>
        <list key="annotations">
          <parameter key="0" value="Name"/>
        </list>
        <list key="data_set_meta_data_information">
          <parameter key="0" value="bla.true.polynominal.attribute"/>
          <parameter key="1" value="split.true.nominal.attribute"/>
        </list>
      </operator>
      <operator activated="true" class="split" compatibility="5.3.013" expanded="true" height="76" name="Split" width="90" x="180" y="52">
        <parameter key="attribute_filter_type" value="subset"/>
        <parameter key="attributes" value="|split"/>
        <parameter key="include_special_attributes" value="true"/>
        <parameter key="split_pattern" value="x"/>
      </operator>
      <operator activated="true" class="multiply" compatibility="5.3.013" expanded="true" height="94" name="Multiply" width="90" x="315" y="30"/>
      <operator activated="true" class="select_attributes" compatibility="5.3.013" expanded="true" height="76" name="Select Attributes" width="90" x="450" y="30"/>
      <connect from_op="Read Excel" from_port="output" to_op="Split" to_port="example set input"/>
      <connect from_op="Split" from_port="example set output" to_op="Multiply" to_port="input"/>
      <connect from_op="Multiply" from_port="output 1" to_op="Select Attributes" to_port="example set input"/>
      <connect from_op="Multiply" from_port="output 2" to_port="result 2"/>
      <connect from_op="Select Attributes" from_port="example set output" to_port="result 1"/>
      <portSpacing port="source_input 1" spacing="0"/>
      <portSpacing port="sink_result 1" spacing="0"/>
      <portSpacing port="sink_result 2" spacing="0"/>
      <portSpacing port="sink_result 3" spacing="0"/>
    </process>
  </operator>
</process>
any ideas why this is so??

Tagged:
Sign In or Register to comment.