Options

(SOLVED) help installing rapidminer server

inceptorfullinceptorfull Member Posts: 44 Contributor II
edited November 2018 in Help
I tried to install rapidminer server it give me at the end
"Service.bat terminated abormally error code : 9.009- rapidminer server service registration may have failed"
although I test the MYsql connection and it worked.

tried to open the rapidminer server
http://koana:8080/

it gives me  white page only


and when try to run the standalone

14:54:49,416 INFO  [org.jboss.as] (Controller Boot Thread) JBAS015954: Admin console is not enabled
14:54:49,417 ERROR [org.jboss.as] (Controller Boot Thread) JBAS015875: JBoss AS 7.2.0.Alpha1-redhat-4 "Janus" started (with errors) in 198478ms - Started 1113 of 1198 services (1 services failed or missing dependencies, 82 services are passive or on-demand)
can anyone help me what to do to make it works?

Answers

  • Options
    Marco_BoeckMarco_Boeck Administrator, Moderator, Employee, Member, University Professor Posts: 1,996 RM Engineering
    Hi,

    Question 1)
    to install it as a service, you need to start the installer with admin privileges. Otherwise Windows will prevent it.
    However you can still start it via the standalone.bat file manually.

    Question 2)
    Obviously I cannot see the entire log, but at that point http://koana:8080/ should work. The part where it says "started (with errors)" can usually be ignored because nothing is actually wrong.

    Regards,
    Marco

  • Options
    inceptorfullinceptorfull Member Posts: 44 Contributor II
    thanks for reply
    but it doesnot work and give me blank page so what may be the problem? also i canot find RM services in windows services
    any help?
  • Options
    inceptorfullinceptorfull Member Posts: 44 Contributor II
    when I re installted it using run as adminstrator , although I got the same error but it worked thanks
  • Options
    JEdwardJEdward RapidMiner Certified Analyst, RapidMiner Certified Expert, Member Posts: 578 Unicorn
    Hey glad to know you got it up and running.  I recommend having a look at the RapidMiner Youtube account.  There's a series of Youtube videos that guide you through setting up webapps from your RapidMiner Processes. 
    That should get you started quickly.
  • Options
    sgenzersgenzer Administrator, Moderator, Employee, RapidMiner Certified Analyst, Community Manager, Member, University Professor, PM Moderator Posts: 2,959 Community Manager
    hi...I'm trying to install a RM Server on a Mac Pro and am getting the same issue - looks like RM Server is running but I get a blank page on the browser.  I have tried several different ways and still get the same result.  The previous comment does not help me (I don't think?) because I am using Mac OS where I am already logged in as administrator...
  • Options
    Marco_BoeckMarco_Boeck Administrator, Moderator, Employee, Member, University Professor Posts: 1,996 RM Engineering
    Hi,

    what does the log file say (found in SERVER/standalone/logs/server.log)?

    Regards,
    Marco
  • Options
    sgenzersgenzer Administrator, Moderator, Employee, RapidMiner Certified Analyst, Community Manager, Member, University Professor, PM Moderator Posts: 2,959 Community Manager
  • Options
    Marco_BoeckMarco_Boeck Administrator, Moderator, Employee, Member, University Professor Posts: 1,996 RM Engineering
    Hi,

    looks like your database configuration is incomplete, it complains that it does not know which database to use. Maybe you forgot to add the schema?
    Can you post the contents of the relevant <datasource> section?

    Regards,
    Marco
  • Options
    sgenzersgenzer Administrator, Moderator, Employee, RapidMiner Certified Analyst, Community Manager, Member, University Professor, PM Moderator Posts: 2,959 Community Manager
    ok that's an interesting point.  When I was installing RM Server, I left schema blank and only then did the "Test Connection" say that everything was ok.  I take it that this was NOT ok?

    I am NOT a SQL person so I just tried to follow the instructions as best as I could on SQL Workbench and hope for the best.  :)

    Scott
  • Options
    Marco_BoeckMarco_Boeck Administrator, Moderator, Employee, Member, University Professor Posts: 1,996 RM Engineering
    Hi,

    this depends on the database system. Oracle is for example fine (or even required) to leave blank. Others require a schema. I dunno why the test succeeded but Server fails though. Probably our test does not cover the entirety of what Server itself needs to do..

    Regards,
    Marco
Sign In or Register to comment.