RAPIDMINER 9.7 BETA ANNOUNCEMENT

The beta program for the RapidMiner 9.7 release is now available. Lots of amazing new improvements including true version control!

CLICK HERE TO DOWNLOAD

changing number format in the results view

bingojosjtubingojosjtu Member Posts: 5 Contributor I
edited November 2018 in Help
Hi,

I have a question regarding the model output in the results view.

What I try to achieve is to obtain the weight coefficient for the weka-logistic regression module.

After successfully running the model, the weight coefficient are presented on the results view.
The good news is that I am able to gather those coefficient values via "write to text" function, but those values are pre-set at certain format, namely 1.2345 instead of 1.23E4.
While I am hoping to obtain the double precision which the model does have (I have printed the model in xml format as well and those values are indeed embedded in it).

So far, I have tried to change the settings/preferences/fraction digits of number values and percentage. Doesn't help. I have also tried format number which doesn't support a model input, as expected.

My original idea is to retrieve the weight coefficient of W-Logistic (just like those in SAS) so that I can use in other program, it turns out to be quite difficult for me to achieve this step.

Any help would be much appreciated!

Answers

  • bingojosjtubingojosjtu Member Posts: 5 Contributor I
    Follow up on the thread,

    I encounter the following link describe how to extract the weight to a example table: https://rapid-i.com/rapidforum/index.php?topic=6726.0

    There are two approaches I would think of,

    first is to extract the coefficient from w-logistic using a similar java script as descried in the lin, but I have zero experience with java script ???

    or find a way to modify the model output format to include more digits in decimals (scientific will be even better).

    If anyone could provide with either of the approach that will be a great help!

Sign In or Register to comment.