Error when generating attributes from data stored in a server repository

lel5287lel5287 Member Posts: 4 Contributor I
edited November 2018 in Help
I have an example set I imported from a csv, and I'm trying to convert a text attribute (comp) to uppercase, so I'm using generate attributes with the formula upper(comp) to create comp2.  This does exactly what I want it to if I place the generate attributes operator after the read csv operator.

Rather than reading from the file every time, I want to save the data to a repository.  If I have the data saved to a local repository, retrieve it from there, and use generate attributes as described above, it does what it should.  If it's saved to a server repository, though, I get the following message when I try to run the process:

"Generation exception: 'Offending attribute: 'comp2', Expression: 'upper(comp)', Error: 'Error during evaluation: Could not evaluate comp: variable not set Error during evaluation: Could not evaluate comp: variable not set"
An operator failed to generate a new attribute, macro, or other object which is created on the fly."

If I just run the retrieve operator, the original data is there exactly like it was when I read it from the csv.  All the metadata is specified correctly (so I should definitely be using a text function on a text attribute).

I'm not sure if it makes a difference where I run the process.  The error message described above occurs if I'm running the process on my own computer.  If I run the process on the server, it supposedly does run.  No errors come up according to the process scheduler.  However. if I try to store my results after that generate attributes operator (just to see if it worked), I get the following error if I try to open those results:

"Cannot fetch data from repository.
Cannot parse I/O-Object: java.lang.ArrayIndexOutOfBoundsException"

My guess here was that there isn't actually anything stored there?  Like, the process didn't actually work, so I have no results.  (Side note: is there an easy way to check as you go how things are running on a server?  Like if your data is doing what what it should be doing as it goes through each operator?)

If anyone has any idea what might be happening here, I'd really appreciate it.  Thanks.
Tagged:

Answers

  • Marco_BoeckMarco_Boeck Team Lead Software Engineering Moderator, Employee, Member, University Professor Posts: 1,806   RM Engineering
    Hi,

    given that you are running Server, you should have access to our enterprise support. Please contact us at https://support.rapidminer.com

    Edit: I saw in your other thread that you are running 5.3 Studio and thus RapidAnalytics 1.3. These are unfortunately vastly outdated and we can no longer provide any support for them in the forums.

    Regards,
    Marco
Sign In or Register to comment.