[SOLVED?] Unknown operator class: 'process'!.

veveveve Member Posts: 63 Contributor II
edited November 2018 in Help

On Friday everythong worked fine. Today: i'm finding myself with this error:

"Process cannot be created: com.rapidminer.tools.XMLException: Unknown operator class: 'process'!."

I'm having this error only when I try to run a process on the server.
The server is up and running.

I tried:
- restarting the server
- restarting the RapidAnalytics server
- removing and adding again the RapidAnalytics repository
- re - install rapidminer

On the server I have the following error:

2014-09-29 09:26:42,797 SEVERE [de.rapidanalytics.web.tools.ProcessServiceDelegate] (http-8088-6) Cannot create process: com.rapidminer.tools.XMLException: Unknown operator class: 'process'!: com.rapidminer.tools.XMLException: Unknown operator class: 'process'!
       at com.rapidminer.io.process.XMLImporter.parseOperator(XMLImporter.java:517) [:5.3.015-${platform}]
       at com.rapidminer.io.process.XMLImporter.parseOperator(XMLImporter.java:492) [:5.3.015-${platform}]
       at com.rapidminer.io.process.XMLImporter.parseRootOperator(XMLImporter.java:351) [:5.3.015-${platform}]
       at com.rapidminer.io.process.XMLImporter.parse(XMLImporter.java:316) [:5.3.015-${platform}]
       at com.rapidminer.io.process.XMLImporter.parse(XMLImporter.java:292) [:5.3.015-${platform}]
       at com.rapidminer.Process.readProcess(Process.java:1108) [:5.3.015-${platform}]
       at com.rapidminer.Process.readProcess(Process.java:1090) [:5.3.015-${platform}]
       at com.rapidminer.Process.<init>(Process.java:259) [:5.3.015-${platform}]
       at de.rapidanalytics.web.tools.ProcessServiceDelegate.executeProcess(ProcessServiceDelegate.java:167) [:]
       at de.rapidanalytics.web.tools.ProcessServiceDelegate.executeProcessSimple(ProcessServiceDelegate.java:88) [:]
       at de.rapidanalytics.web.service.ProcessService.executeProcessSimple(Unknown Source) [:]
       at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) [:1.7.0_67]
       at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57) [:1.7.0_67]

Any ideeas?

Thank you!



  • Options
    veveveve Member Posts: 63 Contributor II
    Worked when I reinstalled the server in another place


    - I think that this is not a real solution
    - I do not understand how come if I installed the server in another place, it still has my process scheduler history (?)

    Thank you!
  • Options
    homburghomburg Moderator, Employee, Member Posts: 114 RM Data Scientist
    Hi Alina,

    did you receive this error with all of your processes? Usually this type of error only occurs when certain processes made with a RapidMiner version 4.6 or older are deployed to the server.

  • Options
    veveveve Member Posts: 63 Contributor II

    yes! even for a newly empty process!
    I never used RapidMiner 4.6. I used only RapidMiner 5.3

    The error just camed back again (I did nothing special!)
    I tried installing again RapidAnalytics on the server but this time it didn't worked...

    Where shoud I change and what in order to make it work again?

    Thank you!

  • Options
    veveveve Member Posts: 63 Contributor II
    I saw that on the folder

    I have a file called ProcessService.wsdl and one ProcessService_1_3.wsdl

    is this ok?

    Thank you!
  • Options
    veveveve Member Posts: 63 Contributor II
    Also, I saw that on the Operators and Extension section from RapidAnalytics  there is none operator right now (it wasn't like this before)...

    Ans, I saw this logs at starting

    [ParameterService] Reading configuration resource com/rapidminer/resources/rapidminerrc.
    13:48:30,164 INFO  [rapidminer] Set locale to en.
    13:48:30,190 INFO  [Launcher] Property rapidminer.home is not set. Guessing.
    13:48:30,190 INFO  [Launcher] Trying base directory of classes (build) 'failed
    13:48:30,198 INFO  [RepositoryManager] Cannot access file system in execution mode APPSERVER. Not loading repositories.
    13:48:30,264 INFO  [rapidminer] Register plugin: WordNet
    13:48:30,265 INFO  [rapidminer] Register plugin: Weka
    13:48:30,265 INFO  [rapidminer] Register plugin: Text Processing
    13:48:30,265 INFO  [rapidminer] Register plugin: Series
    13:48:30,265 INFO  [rapidminer] Register plugin: Parallel Processing
    13:48:30,265 INFO  [rapidminer] Register plugin: R Extension
    13:48:30,265 INFO  [rapidminer] Register plugin: PMML
    13:48:30,265 INFO  [rapidminer] Register plugin: Community
    13:48:30,266 INFO  [rapidminer] Register plugin: Reporting
    13:48:34,590 INFO  [PluginInitR] Trying to load R Library...

  • Options
    homburghomburg Moderator, Employee, Member Posts: 114 RM Data Scientist
    Hi Alina,

    it looks like no operators are loaded during startup. Can you send me your server config files?

    Cheers, Helge
Sign In or Register to comment.