Options

RapidMiner Studio won't start after update to 6.1 (Problem solved thanks Marco)

lanemlanem Member, University Professor Posts: 29 Maven
edited November 2018 in Help
Hi
I have installed RapidMiner Studio 6.1 version on Windows 7 but it will not start up and after providing the option to start in safe mode and disable extensions it simply sits on a logo saying checking license

Any advice on why this is occurring and how to install RapidMiner 6.1 correctly (note I have been using RapidMiner 6 Studio previously with no problems)

Regards Michael

Answers

  • Options
    Nils_WoehlerNils_Woehler Member Posts: 463 Maven
    Hi Michael,

    it looks like something has gone wrong with your update. Please uninstall RapidMiner and reinstall a fresh version of 6.1.
    You won't lose any configuration that way.

    Cheers,
    Nils
  • Options
    lanemlanem Member, University Professor Posts: 29 Maven
    Hi Nils

    I have tried uninstalling RapidMiner Studio 6.1 and reinstalling and this works fine but I still end with RapidMiner Studio 6.1 not being able to start up and offers the option to disable extensions or start normally and regardless of which option I chose it then sits there with a logo saying checking license and thats as far I can get with

    Note I have using the previous version of RapidMiner Studio 6 with no problems for almost a year as a data mining tool for teaching purposes in a postgraduate course on Business Intelligence (students love RapidMiner) and I only encountered this problem when I upgraded from RapidMiner Studio 6.0 to 6.1

    I have RapidMiner Community Edition 5.3 installed and this works fine

    I think that as you said something is not quite right with the installation of RapidMiner 6.1 Studio and there is system setting or something that is not quite right that is stopping RapidMiner Studio 6.1 from starting correctly

    Any help with this will be much appreciated

    Update I have investigated this problem further and from the cmd line it is saying "Error Launch settings could be set Please install RapidMiner correctly... This makes me thing the problem resides in the user  .\RapidMiner folder??? Would it be worth saving the files I need from this folder such as repositories and then deleting this folder to start the RapidMiner Studio 6.1 installation completely from scratch  as I am now thinking that something is screwed in the settings in this folder???

    Regards Michael
  • Options
    Marco_BoeckMarco_Boeck Administrator, Moderator, Employee, Member, University Professor Posts: 1,996 RM Engineering
    Hi,

    there are two potential problems:

    1) When you uninstall RapidMiner Studio, the folder it was in might not be cleaned up 100%. Make sure that the actual folder is deleted so nothing remains. Then do a fresh install.

    If that does not work:
    2) There might be something wrong with some setting. I'm not sure what it could be, so could you please post the contents of the launcher.log and rapidminer-studio.log (both found in the .RapidMiner folder)?

    Deleting the .RapidMiner folder is only a last resort and requires some backup (unless you have stored nothing of value in there):
    - Your local repositories are stored in the repositores folder by default. Make sure to back this up
    - Your license is stored in the licenses folder. Make sure to backup that as well
    - cipher.key is your local encryption key for passwords and such, back that up as well
    - connections.xml contains your database connections if you have defined any
    - configurable-xyz.xml contain settings for other connections like Twitter, Salesforce, MongoDB, Cassandra, etc
    - jdbc_properties.xml contains custom JDBC driver settings if you have any
    - repositories.xml contains structural information about your repositories
    - secrets.xml contains your stored passwords

    Regards,
    Marco
  • Options
    lanemlanem Member, University Professor Posts: 29 Maven
    Hi Marco

    Thank you very much

    Your first suggestion solved my problem - I actually needed to delete all of the remaining files and folders in the RapidMiner Studio Folder and also reinstalled all of the files and folders in the .RapidMiner folder in the system users folder as there were some important files in that folder as you pointed out

    Then when I reinstalled RapidMiner Studio 6.1 everything works fine now including the R extension

    Best regards Michael

Sign In or Register to comment.