can not use R extension

blatooblatoo Member Posts: 32 Contributor I
edited November 2018 in Help
Hi all,

i want to try the R extention, but I got a problem with "Generate Vector". The error message is:

Process failed.
Could not initiate session with native R. Try using server.
Reason: Could not initialize R via JRI.
Reason: Unable to initialize R

How can I fix this problem?

Thanks in advance!

image
https://www.dropbox.com/s/lfbodq9y8b4cimp/Selection_091.png?dl=0

Answers

  • Marco_BoeckMarco_Boeck Team Lead Software Engineering Moderator, Employee, Member, University Professor Posts: 1,769   RM Engineering
    Hi,

    please throw the old R extension away and use the all new "R Scripting" extension.
    Support for the old one has been discontinued as of Studio 6.4 and the new one is much more trivial to set up and use :)

    Regards,
    Marco
  • blatooblatoo Member Posts: 32 Contributor I
    Hi Marco,

    thanks for the answer! I will do it at once!  :)
  • gbortz27gbortz27 Member Posts: 22 Contributor I
    Hi

    Just loaded R extention from the Marketplace and the perspective does not show up , although it did install.

    I am using Widows 7 Pro  and Rapidminer V6

    Can you help ?

    Regards
    Graham Bortz
  • David_ADavid_A Moderator, Employee, RMResearcher, Member Posts: 170  RM Research
    The R extension does no longer have a dedicated R view.
    You can run your scripts with the "Execute R" operator and you can view your results in the normal RapidMiner results perspective.

    Regards,
    David
  • Marco_BoeckMarco_Boeck Team Lead Software Engineering Moderator, Employee, Member, University Professor Posts: 1,769   RM Engineering
    Hi,

    please do not post the same question everywhere. There is an extended answer: http://rapid-i.com/rapidforum/index.php/topic,8821.0.html

    Regards,
    Marco
Sign In or Register to comment.