Options

Write Excel restriction to 256 attributes

limegreenman900limegreenman900 Member Posts: 26 Contributor II
edited November 2018 in Help

Hi,

 

I am trying to export my results of the following process to an excel file:

Process Documents from File (within here some text modification operators) -> Data to Similarity -> Similarity to Data -> Write Excel.

So basically I have around 3,000 files that I want to compare with each other. The process runs fine, until I get to the Write Excel operator (without the operator I can see my results in the RM results view). When reaching the Write to Excel operator I get an error message like "Maximum size reached, only 256 attributes supported". I know that Excel is supporting over 1 Million rows and up to 16000 columns, so what is the point here? I also tried "Generate Report " -> "Report". Although this approach is executed properly, it limits the amount of rows/columns also to 256.... Anyone an idea how to get a matrix of 3,500x3,500 into an excel file after the similarity operation?

 

Any help appreciated!

Tagged:

Best Answer

  • Options
    landland RapidMiner Certified Analyst, RapidMiner Certified Expert, Member Posts: 2,531 Unicorn
    Solution Accepted

    Hi,

     

    are you trying to write into the old xls format? This indeed supported less columns and rows than the new xlsx format...

    I just tested with RapidMiner 7.1. and it outputs 500 columns easily...

     

    Greetings, 

     Sebastian

Answers

  • Options
    limegreenman900limegreenman900 Member Posts: 26 Contributor II

    Indeed, you're right. I had a look at excel limitations and for xls only 256 columns were supported. I'll check my process later on, could be that I chose xls without thinking about this...

  • Options
    Marco_BoeckMarco_Boeck Administrator, Moderator, Employee, Member, University Professor Posts: 1,996 RM Engineering

    Hi,

     

    sounds indeed like you are using a slightly older version of RapidMiner Studio. The latest version automatically preselects .xlsx as output format (as opposed to .xls which had a limit of 256 columns). But you can change your operator manually by changing the "file format" parameter to xlsx.

     

    Regards,

    Marco

Sign In or Register to comment.