Unable to use Process Documents from Mail Store with gmail

gwgw Member Posts: 1 Contributor I
edited November 2018 in Help

After reading this thread and various links (here, here) I am wondering what "connection properties" I should use in order for the "Process Documents from Mail Store" operator to work with my gmail account.

 

Here is my protocol. 

 

<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<process version="7.1.000">
<context>
<input/>
<output/>
<macros/>
</context>
<operator activated="true" class="process" compatibility="7.1.000" expanded="true" name="Process">
<process expanded="true">
<operator activated="true" class="text:process_mail_documents" compatibility="7.1.001" expanded="true" height="82" name="Process Documents from Mail Store" width="90" x="112" y="187">
<parameter key="create_word_vector" value="false"/>
<parameter key="keep_text" value="true"/>
<parameter key="host" value="imap.gmail.com"/>
<parameter key="user" value="[email protected]"/>
<parameter key="password" value="mySecretPassword"/>
<list key="connection_properties">
<parameter key="mail.imap.ssl.enable" value="true"/>
</list>
<parameter key="protocol" value="imap"/>
<parameter key="only_unseen" value="false"/>
<parameter key="mark_seen" value="false"/>
<parameter key="folder" value="Inbox"/>
<process expanded="true">
<connect from_port="document" to_port="document 1"/>
<portSpacing port="source_document" spacing="0"/>
<portSpacing port="source_attachments" spacing="0"/>
<portSpacing port="sink_document 1" spacing="0"/>
<portSpacing port="sink_document 2" spacing="0"/>
</process>
</operator>
<portSpacing port="source_input 1" spacing="0"/>
<portSpacing port="sink_result 1" spacing="0"/>
</process>
</operator>
</process>

 

I've also tried with these parameters

 

<parameter key="Requires SSL" value="Yes"/>
<parameter key="Port" value="993"/>

Answers

  • Thomas_OttThomas_Ott RapidMiner Certified Analyst, RapidMiner Certified Expert, Member Posts: 1,761   Unicorn

    I see you're using gmail. They're really tough to work with. Try this, it works on my end.

     

    <?xml version="1.0" encoding="UTF-8" standalone="no"?>
    <process version="7.1.001">
    <context>
    <input/>
    <output/>
    <macros/>
    </context>
    <operator activated="true" class="process" compatibility="7.1.001" expanded="true" name="Process">
    <process expanded="true">
    <operator activated="true" class="text:read_documents_mail" compatibility="7.1.001" expanded="true" height="68" name="Read Documents (Mail)" width="90" x="45" y="34">
    <parameter key="host" value="imap.gmail.com"/>
    <parameter key="user" value="MYEMAIL"/>
    <parameter key="password" value="MYPASSWORD"/>
    <list key="connection_properties">
    <parameter key="mail.imap.ssl.enable" value="true"/>
    </list>
    <parameter key="protocol" value="imap"/>
    <parameter key="only_unseen" value="false"/>
    <parameter key="mark_seen" value="false"/>
    </operator>
    <operator activated="true" class="text:documents_to_data" compatibility="7.1.001" expanded="true" height="82" name="Documents to Data" width="90" x="179" y="34">
    <parameter key="text_attribute" value="text"/>
    </operator>
    <connect from_op="Read Documents (Mail)" from_port="output" to_op="Documents to Data" to_port="documents 1"/>
    <connect from_op="Documents to Data" from_port="example set" to_port="result 1"/>
    <portSpacing port="source_input 1" spacing="0"/>
    <portSpacing port="sink_result 1" spacing="0"/>
    <portSpacing port="sink_result 2" spacing="0"/>
    </process>
    </operator>
    </process>
Sign In or Register to comment.