database connection : Login timed out

kaymankayman Member Posts: 662 Unicorn
edited November 2018 in Help

Hi, I wanted to connect to my SQL databases using the new RM7.2, but get a time out on any connection that I make.

 

To make clear : 

 

-> The same connections work perfect using RM5 so the settings are expected to be correct (tripple checked that one)

-> I have the problem with connections to different SQL servers, using different credentials (and all of them work using RM5)

I'm running the 64bit version of RM72, and have Java 8 installed. Is there anything else I need to install (drivers?) to get a connection to SQL servers, or is it supposed to work out of the box ?

 

 

Tagged:

Best Answers

  • IngoRMIngoRM Administrator, Moderator, Employee, RapidMiner Certified Analyst, RapidMiner Certified Expert, Community Manager, RMResearcher, Member, University Professor Posts: 1,751 RM Founder
    Solution Accepted

    Although I must admit that I am not 100% since we do not have such an old MS SQL version ourselves for testing, the driver is indeed the most likely cause for this problem.  In RapidMiner 5.3 we have used a circa 5 year old driver file which has been in the meantime updated several times.

     

    Sorry that we can't test this ourselves, but I am actually quite confident that this is indeed the cause for your problem.  So if you have an old version (best case: from MS) of the correct driver, you can install this following this guide:

     

    http://docs.rapidminer.com/server/administration/creating-connections/creating-db-conns.html

     

    Hope this helps,

    Ingo

  • kaymankayman Member Posts: 662 Unicorn
    Solution Accepted

    Shame on me. Turned out in the end I had to select JTDS, and that I had to add the instance a bit differently as for version 5. After that it worked fine.

    So, for those who wonder, you can also use the older SQL monsters (at least SQL2000) perfectly on both server and studio. 

Answers

  • Thomas_OttThomas_Ott RapidMiner Certified Analyst, RapidMiner Certified Expert, Member Posts: 1,761 Unicorn

    Are you trying to connect to a MySQL DB? If so, there was a change in drivers at version 7 because of licsensing changes from them. You'll have to download that driver seperately.

  • kaymankayman Member Posts: 662 Unicorn

    Nope, MS SQL.

     

    Looking at available Database drivers it shows I have 2 drivers available (green ticked) 

     

    -> net.soureforge.jtds.jdbc.Driver

    -> com.microsoft.sqlserver.jdbc.SQLServerDriver

     

    both of the options result in a time out (using RM5 I have immediate access)

     

    Hope this helps

  • kaymankayman Member Posts: 662 Unicorn

    If this helps :

     

    Using a connection to my local SQL express works fine, it's only external databases that do not seem to work as expected.

    The external databases are SQL2000, fairly old but ok, company policy...

    The SQL express is  version 2014.

     

    Could there be a difference related to version? Would I have to install different drivers to be able to connect to SQL2000? Given that RM5 was 32bit this sounds realistic but before I start fooling around I would like to hear more from the experts

  • kaymankayman Member Posts: 662 Unicorn

    Actually I already tried with the older driver, unfortunatly it gave the same problem. Apart from that the new driver should support italso according to the documentation, so I expect it more to be related to the fact I am using the 64bit version of RM.

    Fair enough anyway, it's time to upgrade these ancient monsters. I'll find a way around it

Sign In or Register to comment.