The Altair Community is migrating to a new platform to provide a better experience for you. The RapidMiner Community will merge with the Altair Community at the same time. In preparation for the migration, both communities are on read-only mode from July 15th - July 24th, 2024. Technical support via cases will continue to work as is. For any urgent requests from Students/Faculty members, please submit the form linked here.
Options

Error when installing Rapidminer Stuidio in Ubuntu 164

danielunesp02danielunesp02 Member Posts: 1 Contributor I
edited November 2018 in Help

I am trying to install Rapidminer Studio ubuntu 16.04 and I`m getting this error:

 

~/rapidminer-studio$ ./RapidMiner-Studio.sh
RAPIDMINER_HOME is not set. Trying the directory '/home/daniel/Downloads/rapidminer-studio'...
Exception in thread "main" java.lang.NoClassDefFoundError: javax/xml/bind/DatatypeConverter
at com.rapidminer.license.verification.JarVerifier.verify(JarVerifier.java:130)
at com.rapidminer.launcher.GUILauncher.main(GUILauncher.java:284)
Caused by: java.lang.ClassNotFoundException: javax.xml.bind.DatatypeConverter
at jdk.internal.loader.BuiltinClassLoader.loadClass(java.base@9-ea/BuiltinClassLoader.java:366)
at jdk.internal.loader.ClassLoaders$AppClassLoader.loadClass(java.base@9-ea/ClassLoaders.java:185)
at java.lang.ClassLoader.loadClass(java.base@9-ea/ClassLoader.java:419)
... 2 more

Best Answers

  • Options
    zl1775zl1775 Member Posts: 4 Contributor I
    Solution Accepted

    Assuming you are using openjdk9, add the following line to the shell script

    --add-modules=java.xml.bind

    right after 

    eval \"$JAVA\"

     

     

Answers

  • Options
    Marco_BoeckMarco_Boeck Administrator, Moderator, Employee, Member, University Professor Posts: 1,996 RM Engineering

    Hi,

     

    looks like that for some reason the Java installation you are using does not contain javax.xml.bind.DatatypeConverter.

    Please make sure to use Oracle Java 8 or OpenJDK 8 for RapidMiner Studio.

     

    Regards,

    Marco

  • Options
    lirokuliroku Member Posts: 1 Contributor I

    Thanks, zl1775! Had this same issue under LM; your solution was all I needed.

  • Options
    emidueemidue Member Posts: 2 Contributor I

    thanks!!! it's work for me:

    if [ $# -gt 0 ]; then
    eval \"$JAVA\" --add-modules=java.xml.bind $JVM_OPTIONS -cp \"${rmClasspath}\" com.rapidminer.launcher.GUILauncher \"$@\"
    else
    eval \"$JAVA\" --add-modules=java.xml.bind $JVM_OPTIONS -cp \"${rmClasspath}\" com.rapidminer.launcher.GUILauncher
    fi

     

     

  • Options
    AlandeyAlandey Member Posts: 8 Contributor II

    Is important tell that the adjust is in file "RapidMiner-Studio.sh",

     

  • Options
    Marco_BoeckMarco_Boeck Administrator, Moderator, Employee, Member, University Professor Posts: 1,996 RM Engineering

    Hi,

     

    Please note that we do not support Java 9 yet. To properly run Studio, you need the latest Oracle Java 8.

     

    Regards,

    Marco

  • Options
    mansour_ebrahimmansour_ebrahim Member Posts: 22 Contributor II
    HI, where exactly is the shell script you addressed here?
    Assuming you are using openjdk9, add the following line to the shell script
    If you mean Rapidminer.sh file, I don't see any line there with \"$JAVA\" string
  • Options
    Marco_BoeckMarco_Boeck Administrator, Moderator, Employee, Member, University Professor Posts: 1,996 RM Engineering
    Hi,

    Please see above. You need Java 8.

    Regards,
    Marco
  • Options
    KnightsKnights Member Posts: 2 Contributor I
    Just to also mention, I didn't need to add the --add-modules=java.xml.bind
  • Options
    bendarjambendarjam Member Posts: 1 Newbie
    Thank you it's work for me to add :
    First, If you don't have 8 installed you can do:
    sudo apt install openjdk-8-jdk openjdk-8-jre

  • Options
    cmbrijeshcmbrijesh Member Posts: 1 Contributor I
    edited January 2021
    This solution works for Ubuntu 18.04, we fixed this problem using similar approach based on @Knights 's solution:

    First install Java 8 JDK, JRE

    sudo apt install openjdk-8-jdk openjdk-8-jre
    sudo update-alternatives --config java

    The above command returns something like this in your terminal:

    *0            /usr/lib/jvm/java-11-openjdk-amd64/bin/java      1111      auto mode
     1            /usr/lib/jvm/java-11-openjdk-amd64/bin/java      1111      manual mode
     2            /usr/lib/jvm/java-8-openjdk-amd64/jre/bin/java   1081      manual mode

    Copy  java-8 path from the output in your terminal  i.e.,  something like this,   /usr/lib/jvm/java-8-openjdk-amd64/jre/   

    and add a line to RapidMiner-Studio.sh to set the JAVA_HOME path, just below the comment "# JAVA_HOME set, so use it"   and before the "if [ ! -z "${JAVA_HOME}" ] ; then" statement, it should look something like this

    # JAVA_HOME set, so use it
    JAVA_HOME=/usr/lib/jvm/java-8-openjdk-amd64/jre/
    if [ ! -z "${JAVA_HOME}" ] ; then


    run RapidMiner-Studio.sh in terminal


    We had same issue with RapidMiner 7 as well and the same solutions works both for RapidMiner 7 and 9. 

    This approach helps in not setting Java 8 as the the default in your system, in my case Java 11 remains default, but for RapidMiner Java 8 is used.


















  • Options
    firmanfirman Member Posts: 1 Newbie
    It's been eight years since Java 8 was released. Is Rapidminer going to wait until the extended support of Java 8 ends in December 2030 before they upgrade their Java version?
Sign In or Register to comment.