Options

FP Growth Stack Overflow Error

batstache611batstache611 Member Posts: 45 Guru
edited November 2018 in Help

Hi,

 

I'm text mining on about 50 odd articles about (advanced) manufacturing and wish to see what kinds of words pop up in frequent combination with each other by using the FP Growth operator however it returns a stack overflow error. I'm using -

 

Process Documents from FIles (transform cases -> tokenize -> filter stopwords -> filter tokens by length) --> Numerical To Binominal --> FP growth.

 

For generating the word vector, I've chosen binary term occurences as the metric and for min support on the FP Growth operator, I've kept that at 0.1 (I've tried different values but still get the same error).

 

Is this a bug that I've encountered? Or am I making a silly mistake somewhere? Any and every help is appreciated. Thank you.

Tagged:

Answers

  • Options
    MartinLiebigMartinLiebig Administrator, Moderator, Employee, RapidMiner Certified Analyst, RapidMiner Certified Expert, University Professor Posts: 3,517 RM Data Scientist

    Dear batstache611,

     

    welcome to the RapidMiner Community.

     

    This looks strange to me. I do not see any obvious problem. Is there a chance that you share process and data? Feel free to contact me via PM or email ( mschmitz at rapidminer .com)

     

    ~Martin

    - Sr. Director Data Solutions, Altair RapidMiner -
    Dortmund, Germany
  • Options
    hosmy008hosmy008 Member Posts: 2 Contributor I

    Hello,

    I have the same problem. I have shared the entire message i receive and a photo of the error.

     

    Regards,

    Reza

    error.PNG

     

  • Options
    Thomas_OttThomas_Ott RapidMiner Certified Analyst, RapidMiner Certified Expert, Member Posts: 1,761 Unicorn

    Hi everyone,

     

    Of the top of my head, the process looks correct so it leads me to believe there's a parameter setting that's causing your issues. 

     

    If you're using the Num>Binom operator you should check out what Min and Max parameters.  If you used a Word Vector setting of TF-IDF, you'll have to set the max value in the Num>Binom operator it to assign a true value.  Another way is to set the Word Vector to to Binanary occurances and then Num>Binomal operator max value to 1.0

     

    Give that a try.

     

     

     

Sign In or Register to comment.